NEC ND-3550A have trouble reading old discs

Welcome everyone. Its great to see such a big support for our cd/dvd drives.

Tribute to all those who know how to solve our problems.

If may I I would like to ask about mine problem. I try find cure for that but so far I found only ppl who asked questions about it. Anyway.

I got 2x drives NEC ND-3550A. They both got problem with reading some DVDs I recorded by those drives and also my old Lite-On drive.

Most of the time I use Memorex or Maxell DVD+R. Since I got those drives I got problems with reading all diffrent media. On one of those drives I upgraded firmware (first tried with 1.04 RPC, them I tried 1.05 RPC) but it didnt help. After all I tryed to go back to 1.04 OEM but still nothing. Then I went to 1.Y4 or 05 (not sure now) - still the same but know funny thing happend in Nero. I use 6.0.0.0. I got funny number as option to burn.
6.1x (8418 KB/s)
5.1x (7038 KB/s)
4.1x (5658 KB/s)
3.1x (4278 KB/s)

I dont know what the hell. As soon I will finish this post I will try get newer version of nero to try fix that, but the main concern is to read all disk I got with some really value stuf.

Please help.

  1. Upgrade your version of neroto the latest, aka 6.0.18 i think.
    This problem has been mentioned previously, and if I recall correctly the solution was an update of nero.

  2. Welcome to the problem that most people have. Crap media.
    Memorex rebadge the crappiest media available. Maxell is diffferent. Maxell should be high quality media & you should have no problems with these.

If you are having problems reading discs, try blindwrite suite, clonecd, alcohol or even dvddecryptor to dump the DVD onto your HD as an image file.

Mount the image using either nero, Virtual Clone Drive, daemon tools or Alcohol to mount the image & then try extracting the files you need.

What about fact that my Win XP read my drive as DVD-RM in explorer - what the H@ll is RM? Something is wrong… and I cant stand it!

Does it happen with all different firmwares?

Try removing the IDE devices in device manager & reboot :wink:

yes it does.

I tried many things and still the same.

Good thing by instaling nero 7 I fixed problem with recording, but still have problem with reading some of my old DVD`s. They used be fine, but not any more. :frowning:

Some media degrades rapidly. You can try copying the info on the dvd to your HD using ISOBUSTER, if you can get your drive to recognize that the media is loaded.