Nec ND-3540 100% CPU

vbimport

#1

Hi!

I got a AMD 1800+ CPU and 512 SD ram.
I recently bought myself a dvd burner but I got very dissapointed, cause of the speed of it. But when I ran a speed test in Nero I found out why:

But what I do not understand is why the burner uses 96% cpu at only 8x? :sad:
I am not running any other programmes in the background while burning.


#2

Try checking the secondary channel for your DVD devices. Your hard drives are probably on your primary.


#3

Hmmm… I am not sure that I do understand so I made a screenshot…
btw my (only) harddrive and my burner is on the same IDE cabel…


#4

I think the HD and the DVD burner should be on different IDE channels. The HD should be set to master on the primary IDE channel and the DVD burner set on master on the secondary IDE. I’m definitely no expert though so perhaps others may have an opinion on this…


#5

Looks to me like your Nec is on the Secondary Channel as Master but it is in PIO/Multiword DMA. Should be showing Ultra DMA2 vs Multiword. You could try to download newer VIA chipset 4 in 1 drivers or roll back to STD MS IDE drivers.


#6

I tried to install the newest via driver but that didn’t work…

I really dunno what else to do…


#7

Well first thing I would do is check in your BIOS and make sure your IDE drives are set to Auto Detect and if they are the only other thing I can think of is roll back your VIA IDE drivers to STD MS Dual channel IDE drivers.


#8

Krutselno, you have already posted that your HD and burner are on the same IDE cable. Therefore they are also on the SAME IDE channel. This should not be the case. Please refer to my previous post :slight_smile:


#9

@asecret. If you look at the screen shots his HDD is on the Primary Master UDMA5 and there is no device showing on the Primary Slave so I am assuming that the Nec is installed on the Secondery master, nothing else is showing as installed on either the Primary slave or secondary slave.:slight_smile:


#10

Yes, you are correct in your interpretation of the screenshot. Please accept my apologies. It is a mystery then…


#11

No need to apologize.:wink:


#12

Sofar we know little abot Krutselno’s mobo or chipset…

You will be surprised when you read VIA’s own recommendations on how to connect optical drives on older mobos.

BTW, the CPU usage shown in Nero CD/DVD Speed is only a synthetical value.


#13

Honestly, I think you just need more CPU.

I have a 3.0GHz P4 with 1G of RAM. This is a significantly faster machine than yours, twice as fast on CPU alone. The memory bandwidth on my system is 6X higher too. And my 3540 uses about 70% of my CPU at 8x.

I know that these transfers are theoretically just DMA, but there’s a lot of overhead in ATAPI. I think our CPUs are just getting hogged with these fast transfers.

Time to get more CPU I think.


#14

Sure, a powerful CPU is always good to have.
But I’m sure, a well configurated setup with AMD 1800+ CPU wouldn’t have any problem to burn at 12x or even at 16x.
The most important thing here is the burst speed.

On my old box ($ntel PIII-733) I had no problem to get sweet 8x burns (Litey 812). :slight_smile:
But then my burst rate was 24MB/s, well in parity of an NEC 3540 (here).

Note. Wesociety used a AMD 1533 MHz (133 bus) chip in his 3540 “First look”


#15

@pinto2. Multiword DMA 2 is just one step above PIO isn’t it?? Via chipsets have always confused me with that mode. Anyways I was thinking that the NEC should be in UDMA 2 so his burst rate would be lower than normal. Please correct me if I am wrong.:slight_smile:


#16

crossg, you are right on that :iagree: . IIRC, in speed PIO-4 is equal to Multiword DMA-2, equal to UDMA-0 (~16,7 MB/s).

Link to my previously posted ATA-table.


#17

Thx pinto2, I just saved your link for future reference.:wink:


#18

Hmmm…well I posted my problem on another forum as well, a Norweagian one and one guy had the same burner as me but he had a AMD 1300 MHz-prosessor and 256 MB and he had no problems at all… so I really don’t understand why my CPU cannot take anymore than 8x… :sad:


#19

This is definitly NOT a CPU issue. :disagree:
I have a Benq 1620 and a Pioneer 109 on a 1400Mhz CPU PC and all is fine.

As to your problem:

  1. Did you follow Crossg advice to check the settings in the BIOS?

  2. What does the POST screen at bootup report? (hit “pause/break” when it shows the IDE devices)

  3. Try this: “UNINSTALL” the secondary IDE channel under the devices manager in Windows and reboot. Read this for details http://www.michna.com/kb/WxDMA.htm it’s been written for Windows 2000 but it applies to XP too. Use the “Alternative method” described.

Good luck :slight_smile:


#20

It’s GOOD to hear that it’s not a cpu problem :wink:

BUT, I’ve been in the bios, and it’s on autodetect.
I also pressed pause in when it showed the IDE devices:
Pri. Master Disk: LBA ATA 100 , 80 GB
Sec.Master Disk: DVD-RW ATA 33

I also uninstalled the secondary IDE channel and it shows the same thing as I’ve posted before.

btw my burner and my harddrive is NOT on the same IDE cabel, I just checked it… I know I’ve said so before, but I was wrong :o