NEC ND 3520a - sound playback on DVD's is bitty and has echoes

vbimport

#1

Hi,

i recently purchased an NEC ND-3520a, have had no problems with burning dvd’s but when i play dvd’s the sound is terrible. It is really crackly and jumps alot…also has a strange echo. I updated the firmware to 3.04 official and it is still the same, so i reverted by to original 1.04 firmware. Any help would be much appreciated.

Current system is:

AMD Athlon XP 1700 (1.47ghz)
MSI KM266 m/board
120gb Maxtor
512mb ram
NVida Mx 4000 128ddr
Soundblaster Live 24
NEC ND-3520a 1.04

Thanks


#2

Check whether the drive is running in PIO mode. This happens when its in PIO mode, if so then change it to DMA. To check it go to device manager -> IDE/ATA ATAPI Controllers -> Secondary IDE channel (Assuming you have your drive on secondary channel) -> Properties -> Advanced Settings. And see what is selected as the current transfer mode. Change it to DMA and reboot. If it again goes back to PIO then simply uninstall the secondary IDE channel from the device manager and refresh it (don’t worry it’ll automatically reinstalls it usually with DMA enabled).


#3

hi,

thanks for the advice…however my system now hangs when i try and play a dvd if its using dma mode. i had this problem a while back when i changed to dma mode…any ideas? i remember having to edit registry becasue Nero changes the upper and lower classes in the registry…not sure how to find them again though!

thanks


#4

I am also not sure why DMA makes your PC hang. You can try installing the latest VIA chipset drivers and see if that helps.


#5

What media are you using, and have you scanned the media for errors? Here are a few other possible issues:

1a) Make sure your harddrive isn’t fragmented.
1b) Make sure that your cache (Nero) isn’t being used on an older (slow) harddrive.
2) Check your device manager for possible hardware clashes.
3) Check your IDE cables and make sure they’re not loose or damaged.
4) Try moving your DVD drive to another IDE slot.
5) Make sure you have the latest drivers for your sound card.
6) As stated by optiplex, install newer VIA drivers. Research which set works best with your motherboard.


#6

hey guys,

thanks again for the posts. i’m still having trouble. in regards to Digitall’s post…i meant that the sound playback is bitty on any dvd i play…not copied media…retail movies etc.

However, i’m really not sure what the problem is…when i use DMA mode the dvd will play but then after 10 secs wll hand…but also, if its in DMA mode when i access the hardrive then that make it hang also - could it be a conflict with a hard drive? if so how do i change this…i have two hard drive’s …a 12gb as my sytem drive (c:)…and the 120gb as my data.

It seems to make a lot of noise in PIO mode when playing discs but is super quiet for the first ten secs or however long in DMA mode. So it would be good to get it working properly in DMA. I have all the latest drivers for my M/Board, soundcard, etc…

HELP guys! haha…thanks.

Dave


#7

I strongly feel that your problem with audio and video is cause by running the drive in PIO mode. Do you have your hard disk on the same IDE cable as the ROM ? If so; move the ROM to the secondary channel and have the Primary and your secondary hard disk on the primary channel. Also as I said before check your cables (use 80 line ATA cables if possible, however DMA will work perfectly with an ordinary 40 line cable as well under 33/66 which is the most common mode for DVD ROM drives).


#8

Hi again…

i agree with u on the PIO mode, it definately seems to run better on DMA, but only runs for a few secs before hanging…its really strange. I’m not a complete amateur with comps, but never had much dealings with optical hardware thats why i need some help. I went and bought a 133 IDE cable…couldnt find any 80 conductor…unless it is one! I thought it may have been the cable…he drive has always been on secondary IDE with my two HDD’s on the primary as master and slave. I also have a ZIP drive as my secondary slave…could this be conflicting?

Also, is there any way of uninstalling my mainboard drivers so i can revert to original instead of updated ones…as when i first got the drive it worked ok and then i reformatted about a week ago but didnt have the original driver cd for my mainboard so i downloaded one…maybe i got the wrong one?

thanks for all the help…sorry for being a nuisance!

:slight_smile:


#9

hey, just thought i’d post a quick reply to see if u had anymore ideas on the nec drive? i have put a detailed reply on the post. thanks


#10

thanks alot for all the help guys…i finally sorted it out! finished my essay very late and decided to stay up a bit longer sortin this out…it seems it had a conflict with the IOMEGA ZIP drive (secondary slave)…so i diabled it and now my dvd writer works great on udma-2…thanks again all

dave