NEC nd 3520a firmware help

vbimport

#1

hey. i got the NEC nd3520a OEM from newegg like about 3 months ago and was using it fine. then recently this past week i foudn out that updating the firmware will help the burner read faster depending on wut dvd-r i use and such. so i goto the NEC website and download the latest firmware update. i did everything according to the steps but after i installed the latest firmware. windows wouldnt detect my drive as a dvd burner and nero wouldnt either. so im like wuts going on and go back to the NEC website and on the bottom says dont install this firmware for OEM drives…so does this mean my drive is completely useless and cant burn. or is there a way around this. can i “downgrade” firmware from any websites?

i did this because my 8x dvd-r’s were burning at 6x and thought i wanted it to burn the full 8x

also…i read on other forums that you can “flash the firmware for nero” to make it burn faster or up to the dvd-r’s speed like the 6x for me would burn at the full 8x. is it possible to “flash the firmware for nero”?

thanks a lot guys for any ideas or help you can provide.


#2

Question? What was the Firmware version # that you flashed 3520 with??


#3

it was v3.04 i THINK i had 1.04 i believe. i got it today from the NEC website. when i rick click properties it it says its file version 1.2.4.4 the file is called W352GF40.


#4

my question is. is it possible to degrade everything to like it was b4 i got the Fw and after that if its possible to upgrade it so its “better”


#5

You gotta be kidding me. What kind of support is this?? Is this an isolated incident or is this true that the official NEC firmware wont work on the drives from newegg?? :Z


#6

You need to flash exactly as it is stated Here. Sounds like you have the right FW so I would try to flash again. A read thruogh the Nec Faq’s might help you out. Yes you can also flash back to older FW but that is explained in the Faq’s as well. This is just me and some people say not required, I usually power off my machine for a couple of minutes after flashing to new FW. If you don’t want to follow the exact instuctions at least roll back your IDE drivers to Standard MS drivers before flashing. Hope this helps.:slight_smile:
BTW, Just so you are aware there are modified versions of this firmware available on this forum with Bitsetting and riplock removed, but you take the chance of voiding your warranty if you use it.


#7

crossq, If you give out a link, pleae make it one everybody can use!!!


#8

I don’t know what happened to the link as I checked it before I posted. It is the link to the Nec firmware flasher instruction page, Happened last night as well when I posted a different link and this is what the link is now:
http://fcx(this.href);/ :confused:

Try this: http://support.necsam.com/oem/downloads/flashfirmware/readme.asp?ID=7


#9

yea i did WORD FOR WORD on that website. thats the one i got it from. i did it 2 times and after installign firmware i had my computer off for a few hours to be safe lol but it still didnt work. it still does the same thing. is there a way i can uninstall this one that i got? i tried “rolling back” drivers or uninstalling it but didnt work…im thinking system restore but thats the last thign i really want to do…are there ANY other ideas please?


#10

Don’t know if I am understanding correctly! So you never did get your drivers rolled back to STD MS drivers?


#11

ok ill try to explain more clearly

i installed the firmware from the NEC website for 3520a drive. that messed with my drive because now in my computer it says cd-rom drive D: and also it will not read dvd’s or burn them.

i tried uninstalling the drivers under device manager and that did not work.

i tried to “roll back driver” but that did not work because i never had a driver in the first place to start with it says.

SO…is there a way to fix this or uninstall the firmware i got or is it permanent.

i even tried system restore just now and that did not work…so now im hesitating because i dont want to purchase another drive.


#12

Try this, Go to Device Manager and under ATA/ATAPI Controllers you should see Ultra ATA storage controllers>Right ckick and select update drivers>Select Install hardware from a list or specific location>next>Don’t search I will choose the drivers to install> next> You should see “Standard Dual Channel PCI IDE controller”. Select and click next. You may need a reboot or you can right click on My Computer in Device manager and scan for hardware changes. Once you are sure the STD MS drivers stay then you can Flash. HTH.
This http://club.cdfreaks.com/showpost.php?p=1000722&postcount=7 is also a way of getting back to MS drivers if you have NVidia drivers installed.


#13

i dont see “ultra ata storage controllers” i only see 3 choices, they are

  1. nvidia ck804 adma controller (v2.7)
  2. nvidia ck804 adma controller (v2.7)
  3. nvidia ck804 parallel ata controller (v2.7)

im sorry im a real big noob at this kind of stuff heh. .


#14

so im just guessing i gota purchase another drive?


#15

I am not familiar with those drivers, but I really don’t see the need for another drive. You should be able to flash your drive. Microsoft Windows normaly has it’s own version of IDE drivers so just have a look under these and see if you can find the STD MS drivers, Did you also check the other link I posted on how to remove NVidia IDE driver.:slight_smile:

  1. nvidia ck804 adma controller (v2.7)
  2. nvidia ck804 adma controller (v2.7)
  3. nvidia ck804 parallel ata controller (v2.7)
    Any one else have any ideas???

#16

<<<I would start looking in Bios and make sure your IDE setting for the Drives are set to Auto Detect, Think the best way to remove NVidia IDE drivers is through the Control Panel>Add and Remove Programs> Nvidia Drivers> Click change/remove>Uncheck IDE drivers> restart. Should go to default MS drivers. Check for Mobo Bios updates as well.
@Farzl. Just preference and won’t solve the problem but I would set the Nec as Master and the CD-Rom as slave.>>>

hmm this kinda sux now…created another problem NOT for this thread but…i did that wut u told me to…then i restarted. it loaded windows then i set the resolution to max ( i always do ) then my moniter just went black so im like wut happened so i restarted. it loaded up but NOW when its on that screen “now loading windows” and the bar is going across. it goes to “the blue screen of death” for a split second then disapears then restarts…so now i cant even load windows. :frowning: i cant believe just trying to fix my dvd burner did all this :frowning:


#17

and yet another problem… im trying to load the hardrive set in SATA. (im using WD raptor 74gb) and i have a regular maxtor ide hardrive but im not sure how to load sata in slave and the ide in master without having conflicts.


#18

sorry for all these posts heh but…

im just tryign to load the sata in slave so i can back up some files on the maxtor drive. then format the sata and use that as master once again


#19

ok sorry for keep wasting ur guys’s time lol… i just fixed that problem i just said and im back to square one…the nd 3520a is still messed up…can someone just recomend a different thign to flash it with? mine is oem


#20

For one thing S ATA drives do not have a Master or Slave, so you should be able to just plug it in and it will show up in Windows or BIOS, are you sure you didn’t uninstall your video Card drivers instead. You just needed to uncheck the IDE drivers.
BTW. What vesrion of Windows are you Running?