NEC ND-3520 flash problem

I’ve been having trouble flashing my 3520 drive. I originally put on 3.04 but I still want bitsetting. I’ve tried multiple f/w’s but they all have the same result. It says ‘sending firmware to drive at 0x006000’. The light on the drive flashes but the program hangs and i have to reboot.

Have I misflashed and now have a defunct drive? For some reason I"m thinking I haven’t because the drive still burns and plays cds/dvds fine. But I can’t even put the 1.04 f/w version back on. Any help? Thanks a ton, this is really frustrating.

Matt

I’m having this problem with my drive too. I’m trying to flash my ND3520A with the newest modified firmware, but I’m getting the exact same thing you are. Anyone know how we can fix this?

2520 in the title…

Try to use the tool in SAFE MODE.

fixed the thread title

Thanks for the suggestion. I tried flashing in Safe Mode, but when I pressed the “flash” button, I got a message saying that the file didn’t have the right firmware version for my drive or something like that. I have a ND3520A and tried flashing it with the 2.U4 quiet firmware.