NEC ND-3500AG problem. Please help!

I have been having this problem since I got a new system a few months ago. My NEC ND-3500AG drive seems to lock after I have used it. For example I would burn a few dvd’s etc then when I close the drive empty the light sticks on and when I try to eject nothing happens for about 1 minute then it finally ejects.

This never happens with a dvd/cd in the drive and if I leave it alone the light just stays on until I shut down. It doesn’t affect anything else in windows or my other drive or running any programs. Sometimes when I have been using the drive and I reboot windows, the dvd light sticks on and windows loading hangs on a black screen until I press the eject button on my drive. Again this only happens when the drive is empty.

Apart from this problem, the drive works perfectly. It has burned all dvd’s I have tried with no problem at all and plays everything ok too.

Any help on this would be much appreciated.

Feel really stupid now!! After all this time with this problem I only just started playing around as it was never a big problem before, only just started getting annoying.

Anyway, I only just realised, I almost ALWAYS have a cd in my other drive which is a samsung cd burner (I am constantly playing games so leave the disc in for convenience) so I tried taking out the disc and then trying opening and ejecting my empty NEC drive and now no more sticking whatsoever!!

Sorry about that, I should have really tried things like this out before posting, something so simple just never crossed my mind.

Not being very technical when it comes to comps though, I would still be curious to know exactly why my NEC drive sticks only when I have a cd in my other drive.


Welcome to the forum
If this problem has only started when you got your new system. You could check the following.

1, Try a new 80 conductor IDE cable
2, Check your BIOS setting sand make sure all the IDe channels are set for Ultra DMA mode.
3, Use Microsofts default IDE drivers rather than a 2rd party IDE driver.

No problem. I’m glad it’s sorted :slight_smile: