NEC ND-3500 Writer buffer empty but memory buffer full?

Hi!

I noticed a weird problem that just appeard. Was burning a movie with DVD Decrypter, TDK002 @ 12x, NEC ND-3500A 2C8_SE_Ritek_4X_DL (because this is the firmware that gives me best results on TDK002)

The burn started out at 6x as it should be but I immediately noticed that the device buffer was empty. The buffer (program’s buffer) was showing full. At about 40% of the burn the program’s buffer suddenly emptied, burn slowed down and the device buffer came alive, filled to 100% and then the program buffer also filled up to 100%. After that I had a normal burn with minor fluctuations with both driver and program buffer, but the speed was limited, ranging from 5x-11x.

I rebooted the computer and tried again on my last TDK002 media, same thing. As I had no TDK002 media left, nothing was stopping me from upgrading the firmware so I loaded 2TD to the drive, rebooted and hoped that the problem would have gone away, but no.
Burning a movie on RICOHJPNR02 @ 16x, NEC ND-3500A 2TD was the same as before, burn starts out at 6x with an empty device buffer, later on the program buffer empties and the drive buffer kicks in. Screenshots and log from the RICOHJPNR02 burn below.

I am positive that the drive runs in UDMA2-mode as transfer rate test and data verification reaches up to 16x, so it’s not the hard drive limiting the speed either.


I 00:07:56 DVD Decrypter Version 3.5.4.0 started!
I 00:07:56 Initialising SPTI...
I 00:07:56 Searching for SCSI / ATAPI devices...
I 00:07:56 Found 1 CD-RW, 3 DVD-ROMs and 1 DVD±RW!
I 00:09:09 Operation Started!
I 00:09:09 Source File: C:\....img
I 00:09:09 Source File Sectors: 2*272*346 (MODE1/2048)
I 00:09:09 Source File Size: 4*653*764*608 bytes
I 00:09:09 Source File Application Identifier: NERO BURNING ROM
I 00:09:09 Source File Implementation Identifier: AHEAD Nero
I 00:09:09 Destination Device: [1:0:0] _NEC DVD_RW ND-3500AG 2.TD (H:) (ATA)
I 00:09:09 Destination Media Type: DVD+R (Disc ID: RICOHJPN-R02-03) (Speeds: 2,4x; 4x; 6x; 8x; 12x; 16x)
I 00:09:09 Destination Media Sectors: 2*295*104
I 00:09:09 Write Mode: DVD
I 00:09:09 Write Type: SAO
I 00:09:09 Write Speed: 16x
I 00:09:09 Link Size: Auto
I 00:09:09 Test Mode: No
I 00:09:09 BURN-Proof: Enabled
I 00:09:10 Filling Buffer...
I 00:09:13 Writing LeadIn...
I 00:09:35 Writing Image...
I 00:16:39 Synchronising Cache...
I 00:16:40 Closing Track...
I 00:16:51 Finalising Disc...
I 00:17:05 Operation Successfully Completed! - Duration: 00:07:55
I 00:17:05 [B]Average Write Rate: 10 743 KB/s (7.8x) - Maximum Write Rate: 15 048 KB/s (10.9x)[/B]
I 00:17:05 Cycling Tray before Verify...
I 00:17:21 Operation Started!
I 00:17:21 Source Device: [1:0:0] _NEC DVD_RW ND-3500AG 2.TD (H:) (ATA)
I 00:17:21 Source Media Type: DVD+R (Disc ID: RICOHJPN-R02-03) (Speeds: 2,4x; 4x; 6x; 8x; 12x; 16x)
I 00:17:21 Verifying Sectors...
I 00:22:23 Operation Successfully Completed! - Duration: 00:05:02
I 00:22:23 [B]Average Verify Rate: 15 048 KB/s (10.9x) - Maximum Verify Rate: 21 781 KB/s (15.7x)[/B]

Write:

Transfer read test:

The graph is not good but that might depend on the lousy burn, I have gotten better results at 16x with this media.

Thx

Hi!
I made another burn, same media (RICOHJPNR02), this time with Alcohol 120%.

Same this time BUT I also noticed that my NEC seems to burn CAV even on 12x. Before it has always started at 6x, switched to 8x at 16-17%, then up to 10x and then 12x, but this burn is CAV, check the pic! Strange is though that the burn kept going up to 10.3x which doesn’t show in the chart but it was at app 10.3x when the probs started around the 2gb mark. (I know that 16x burns are CAV but 12x have always been Z-CLV for me).

Burn:

Transfer Rate Test:

Maybe the buffer level reporting was wrong. Use CD-DVD Speed to create a data disc. You can configure CD-DVD Speed to write a disc image if you don’t want to “waste” a disc. Post the results.

PS: The transfer rate graph in your first post is perfect. Why did you say that it was bad?

PPS: You can attach scans to your post if you want (instead of finding external hosting)

Thanks for your input code65536!
I wrote an iso with CD-DVDspeed and it looks like this:


Not that great, I’ve had much better burns with this media. Tried 4 different discs, 2 different media, same error, I guess I’ll have to start searching for errors elsewhere.
Read transfer is good:

PS: Well, the first read transfer is ok, you can clearly tell that the burner had severe problems at the end. The second and this (third) transfer rate test are great though

PPS: Thank you, I saw the attachment button but it’s no prob for me hosting the images.

PPPS: I’m getting some new media, YUDEN000T02 and MCC03RG20 (on friday, if they hurry with the delivery :slight_smile: )

Yo-

One thing that I have learned with both my 3500’s - they are very RAM usage intensive when doing big movie copy burns - so I have 1gb on my media computer with the LiteOn 1693s and the NEC 3500 and 2gb on my work computer with the AOpen 1648/aap Pro and the NEC 3500-

Getting very good burns on both-

Mike

I “solved” it.
Although I knew that DMA was activated (read went up to 16x) I deleted all the IDE controllers in the Device Manager and rebooted. After reboot, the computer told me that it found new hardware, but that the driver I had wasn’t for this version of Windows (very strange, it was the same Microsoft-supplied default driver that I’ve always been using). Anyway, deleting and another reboot didn’t help, so I figured, I’d try with the VIA drivers (yes I know they are awful but better it works than being broken). So I installed the VIA drivers, which made my computer go crazy about devices. For some reason my Daemon Tools virtual drives were listed first in Nero CDSpeed, and if I tried to select either my CD or DVD-burner, CDSpeed would just freeze -> reboot. It also was impossible to watch a DVD with PowerDVD, freeze and reboot.
So I got tired of the VIA drivers, uninstalled them and after a reboot, it found the controllers again, but this time it didn’t complain about the drivers and installed everything (same MS drivers that I used before). Weee!
So I dunno, basically something was wrong, and I guess I’ll never find out, but it works now so I’m happy.

Maybe this can help someone out who’s in the same situation.