NEC ND-2510a shows up in PIO Mode

vbimport

#1

Specs: XP Home, 2600+, Asus a7a266 motherboard.

I’m having problems burning CDs on both my DVD burner and CD burner (strangely enough, burning DVDs is fine with the DVD burner).

Both drive are on the secondary IDE channel. Both have transfer mode set to “DMA if available”, but the NEC ND-2510a burner shows up as PIO Mode. I’ve tried removing the channel and rebooting to reinstall, but it doesn’t help.

Firstly, should the DVD drive be in DMA mode and if so, how do I force it?

Thanks,

P.


#2

Try to go into the device manager and delete the IDE channel where your drive is connected and reboot. After reboot, it will redetect the drives and hopefully go back into DMA mode.


#3

Hm, when I reread your post you already did it, sorry.

How about your bios? How about changing the two drives on the cable (interchange master and slave respectively)? Is the CD-writer in DMA mode?


#4

got the same problem before
i know dell got a thing that force slave drive to dma mode
but after you re-start your computer again
it will go back to pio
this is what some people tell me to do
when you start your computer
press F2 or 10 (depend on your computer) to go to the setup
turn your secondary ide slave one on (not sure what you call it)


#5

Got the same problem with Dell SC420 after adding NEC ND-2510a. I forgot that I had set the secondary drive to “off” for some reason. Resetting it to ON in the bios setting solved the problem. Thanks for the reminder.:slight_smile:

BTW it’s F2 at boot to get to bios setting.