NEC AD-7590A-01 master to slave?

vbimport

#1

Hey guys,
Im new here and decided to join since this place seems to be the best place for the issue i am having.Well where to begin,I just purchased a new NEC AD-7590A-01 DVD +/- RW DL burner as a replacement for my laptop burner which recently died.I have a Toshiba Qosmio F-25 AV205 and i already read that i will need to switch my new NEC drive to slave via tools from NEC.I also purchased a slimline to IDE converter for this purpose.After contacting NEC they e-mailed me back with the tool in question telling me i needed to conect the drive to my desktop via the converter then run the tool to change from master to slave jumper settings.

After connecting the drive to my desktop it is reconized as a Sony NEC Optiarc AD-7590A-01 but when i run the tool “Optiarc_G540_ReverseATA_Tool” i get a message saying “Target Optiarc DVD drive is not found correctly” i tryed connecting it as per instruction to each IDE connector making sure that it was also the only device on that IDE channel but nothing seems to help and i get the same error every time.Now im pretty stuck and just e-mailed NEC support again but thought i would also ask here.Any help would be great.


#2

Looks like they sent you the wrong tool. The G540 tool is meant for AD-7540/7543 drives. Unfortunately I still don’t know the “official” commands for switching a drive between CS, inverse CS, master and slave so I cannot write a reliable program for this task myself.


#3

thanks Liggy,
Looks like you were correct,i got a response from NEC Tech support this morning and yet another tool “G590A_ATAChange_Tool” this one worked like a charm so i thought i would post it for anyone else having the same issue and maybe it’s of some use to you as well.Thanks again for the time.

G590A_ATAChange_Tool.ZIP (22.4 KB)


#4

You just saved me from having to contact Nec tech support to request the same tool. Thanks.


#5

I’m trying to install this drive in a new server.

I’ve got two hard drives installed on the primary IDE channel and have this DVD drive installed on the other IDE channel (via a norco slim to IDE converter cable). I’ve done this successfully on another server, but this time the motherboard BIOS seems to get confused when the DVD drive is hanging there and it will not find the hard drives (even though they are on a different channel). The mother board manufacturer said I have to find a way to switch the DVD to slave mode so I tried the “G590A_ATAChange_Tool” and set it to slave, and it hasn’t solved the problem.

Any suggestions?

-Mike


#6

Oh, also… My drive is a “sony optiarc ad-7590a” and I am assuming it is the same drive represented in this forum… just that Sony must have purchased the manufacturing rights to it. Can anyone confirm?