Nec 6650 read errors in dell c610

I’ve installed a 6650 in a dell c610. In reading some of the other posts here on this site I’ve found a few references to the problem I’m having, but not really a resolution. I’m finding:

  1. It can burn anything I’ve tried so far but can’t read the images back for validation when burning on newer (16x) +/-r media. Any of my other 5 drives can read the dvds the 6650 burns without error. I usually burn at the lowest speed the software allows.

  2. It can’t read anything burned elsewhere, on 16x-capable media. It can usually, but not always, read anything on slower-capable media. It also can’t read some (newer) commercial dvds (not sure of media).

I don’t need anything more than 2x speed for writing or reading, I just need to be able to read most dvds. The identical problem occurs regardless of which of my c610s I use the drive in (1ghz or 1.2ghz) and which operating system I use (opensuse, fedora core 6, xp pro). The failures occur randomly (reading the same dvd produces read errors at different locations.) Sometimes it can read 3.5gb of a 4gb dvd without any errors, then it errors out. The the same dvd will error out without a few seconds of starting to read. So far it has not had any errors reading dvdrw (2x) or much older dvd+/-r media, and only 1 error so far on 8x-capable media.

The media has been various brands.

The drive came with the 2006 firmware, but I have tried some of the older firmware files from the download page. There is no difference in read behavior with any of the firmware I’ve tried.

Any suggestions would be appreciated.

Couple things to try:

  1. Always use good brand names for media: Taiyo Yuden (TY), Verbatim, Fujifilm, TDK, etc. Do not buy junk brands because they are cheap…because they literally are.

  2. Most dyes used in 16x media does not like to be burned slowly. Ex: 2x/2.4x or 4x. The slowest you should burn at is 8x.

  3. Use the latest firmware for the ND-6650. This is the Dell version 203d/403d…2xx being for master-mode drives and 4xx for slave-mode drives. Do not try to flash between them or try to convert your drive to a slave-mode just to try the 4xx firmwares.
    http://liggydee.cdfreaks.com/page/en/NEC-ND-6650A/