Nec 6500a crossflash

Hi

Since there are new dvd and cd discs for up to 16x speed burners i had problems with writing onto such dvds, and i wanted to upgrade my Nec Nd-6500a firmware…

Unfortunately i chose the false firmware (i should stick to 2.xx but flashed it to 4.60) and crossflashed it… now i still can write to dvds but still only to old ones, cds are without a problem… i tried to flash it backwards but no program supports this,… there is always a prompt that i have the false firmware for this device (funny this didnt happen when i crossflashed it)… sometimes the system doesnt recognize my cd drive well, and on startup it takes pretty long…

What can i do? please help me

kiark

PS: Sorry for my bad English, its not my mother language :wink:

You cannot crossflash a 6500 anymore.

Look at Liggy & Dee’s site.

chef - What are you talking about? I think he mistakenly used the term “crossflash” for switching between master & slave firmwares (not sure if he did the bootcode by his original post).

kiark - Please be extremely specific with which files and programs you used. We can’t tell if you updated the bootcode along with the firmware. Also I don’t even see a 4.60 firmware, so that is making things even more confusing.

Hi

First of all, thanks for your quick answers :wink:

I flashed it some time ago, a few months ago i think… i was using binflash but im not 100% sure about that,…

what makes me think i have firmware 4.60 is, that when i was trying to reflash my drive with TDB’s firmware flasher, the device is shown with firmware 4.60…

The funny thing about all this is, that the burner still worked, even with the false firmware,… im not really good in computers,… is there anything i can do to give you better answers, or maybe some type of diagnostics?

kiark

http://tdb.rpc1.org/#ND6500A
http://liggydee.cdfreaks.com/page/6500/

Both sites do not show a 4.60 firmware at all. Please either use a tool like Binflash, Nero InfoTool or CD/DVD Speed, or DVDInfoPro to post some detailed info about your ND-6500.

I just responded to what he wrote. If he writes “crossflash” then I can assume that he means “crossflash”, not?!

chef - Ok, I see your point. But he didn’t mention anything about an ND-6100 or ND-6450, so I took it as he goofed and somehow flashed a “4.60” firmware…but can’t remember where he got it from. Heck, even Liggy & Dee refer to it as crossflashing on their page.

[B]Do NOT try to crossflash between 2.** and 4.** firmwares by using Binflash. This is very likely to DAMAGE your drive or make it INACCESSIBLE![/B]

Anyway, I think all he needs to do is use the DOS master bootcode flasher which should make sure his drive has a master bootcode and then he can switch back to a master ND-6500 firmware (i.e. the 2.xx firmwares).

kiark - Do like I said above and use the master bootcode flasher (also referred to as Normal bootcode flasher). Then flash the 203d firmware which is the latest for your drive. If you still have media recognition problems, then you will have to learn how to use Media Code Speed Edit to customize the 203d firmware and then reflash it.

Hi

I was running Nero Info Tool now, and it also says me that i have firmware 4.60 :confused:

i made a few screenshots to let you see



I was also trying to use the master bootcode flasher, but after some time it says that there are errors with sending information to the drive :confused:

Thanks for all the help

Edit: i think i found the page from where i had the firmware

http://www.micheldeboer.nl/firmware/6500.html

kiark

Good, we both have a point then. :bigsmile: :flower:

Ok, that firmware is a slave firmware. It looks like your drive is actually uses a slave bootcode/firmware (4.xx), but the laptop BIOS does some remapping so that it appears as a master on the secondary IDE channel.

With that said, you should use the Dell firmware 403d that is on either site. If you don’t know which firmware variation to use (Orig, Fast, or RPC1) then just pick the Original one. Or consult the NEC FAQ for more info.
http://liggydee.cdfreaks.com/page/faq/

Hi

I treid to flash the dell Firmware but it stops after a while, because it has some errors with entering passive mode… :frowning:

Kiark

PS: thanks for your help again

Did you use the Windows GUI version of binflash (aka NecWinFlash.exe)?
See if the latest version can backup your current firmware successfully…even though you can download it again from that website.

If that goes ok, perhaps you need to boot into Windows Safe Mode and try the flash process.

I have the same problem.

I inadvertently “crossflashed” my 6500 drive. prevoiusly I used firmware 2.8x and then I flashed it with Version 4.60.

The miracle is: I can use my drive just as normal, watching DVD, burning CDs, burning rw-DVDs works well. I suppose that even burning 8x DVDs would work, if I only had such a disc.

Lets talk abut the things that don’t work. I can’t burn 16x DVDs and unfortunately that are the only discs that are nowadays sold. Flashing a different firmware doesn’t work either.

I tried booting dos from a floppy in a normal desktop PC with a slimline-adapter, but the master-bootcode flasher does not recognize my drive although the bios lists it as a master drive.

Any sugestions, help? I’m so desperate…

Ok, here are some more facts. Bootlash finds two NEC nd-6500 drives on my laptop although I only have one.
Regardless which one I’m trying to flash, I always get the same error message. After that the drive LED blinks fast and the drive isn’t responding anymore. After restartring i have my nd6500 master back, but it still has the slave firmware.

Please help me, I’m so desperate.



The problem is still unsolved, but I found an interesting fact.

I tried just to flash the right firmware again. Binflash 1.42 finds one drive, says first that I should try to change the Bootcode (which doesn’t work as explained earlier) an then claims that firmware is for a different drive (which is not true as I used exactly that firmware earlier).

Binflash 1.39 shows a different behaviour, I will explain this in my next post, but first i have to boot because the drive is blinking and doesn’t respond anymore.



Ok, as explained in my previous post, Binflash 1.39 shows a different behaviour.

It first gives an errormessage about mixing master and slave (in fact i’m trying to install uniform master firmware) and then claims that drive and firmware report different drive IDs and stops.

Woluld it be a solution to use the “NEC Drive Converter 1.40 (by Liggy)” found at http://www.micheldeboer.nl/firmware/utilities/driveconv140.zip?

any help appreciated

error dont cont.jpg
different IDs.jpg



The different behaviour between version 1.39 and 1.42 is caused by a code that was introduced in version 1.40. It contains an additional check to ensure a matching bootcode.
ID from drive=85 means your drive is set to slave, while the id=84 from firmware shows that you want to flash a master firmware.

However I cannot really interpret the “found=0xffff” part. Something seems to be very wrong here, but I don’t know what exactly it is :confused:

thank you for your reply.:slight_smile:

As far as i understood the problem, the bootcode of my drive is still a master bootcode, but the firmware is (inadvertently) a slave firmware.

That itself seems to be the reason why I can’t either change the bootcode or the firmware.

The bios or firmware seems to do some wild remapping and I’m lucky that I can access my drive at all. However this remapping does not allow to reinstall uniform master firmware and bootcode.:frowning:

It seems, that there is no way back ton uniform master firmware and bootcode, so lets look if there is a way to uniform slave bootcode and firmware.

When I tried booting dos from a floppy in a normal desktop PC with a slimline-adapter, the slave -bootcode flasher does not recognize my drive.

Some reported, that they converted masterdrives to slavedrives and vice versa by connecting or disconnecting some pins at the ide interface. Would it be possible to do this temporarily, just to allow the bootcode-flasher to recognize my drive?

Which pins do I have to connect/disconnect?

Any help appreciated

I think it will be almost impossible to get your drive back to the same bootcode and main firmware. The problem is that when you flash your drive (main firmware AND bootcode), you stop using the main firmware and switch to the bootcode because that’s the only place which has commands for flashing.

Unfortunately the IDE mode of your drive changes, when you switch from main firmware to bootcode or vice versa. This will probably confuse any operating system. What you would need is a way to send the command for switching to the bootcode to one device and everything else to another device. I highly doubt that this is possible within any “higher level” operating system. The only way I could think of is using DOS with direct access to the IDE ports. Unfortunately I only have my routines that depend on a loaded ASPI driver and I have no idea how to access the IDE ports directly.

NEC 6500 has many hardware versions. Compared with other ones, my Olympus-OEM version accepts both 2.xx and 4.xx in the slave condition. They’re both recognized from Win2000 and XP on my two laptops. Now it’s master because my new machine doesn’t support CD-ROM boot on slave even my old one does.

Calliano - Have you tried 4.25 yet? If your OS recognizes your drive’s (maybe different hardware version from mine) master and slave by the firmware number, 4.XX would make sense. But it’s at your own risk.