NEC 4570a

All blame is accepted by myself as i used it at my own risk, so you can feel free to call me an idiot but, can you help :smiley:

I was having trouble with my dvd drive so i used the flash utility from scorpiosofts page.
http://www.micheldeboer.nl/firmware/index.html

now when i start my pc it hangs whilst loading

“detecting array” is the message it displays. So i’ve obviously knackered my dvd drive. If i unhook it, xp loads up. if i plug it in it displays the message :frowning:

So obviously i cant use the flasher to undo it as i can never get into windows with the dvd drive plugged in.

Is there any way i can undo what i did :confused: cheers.

Is the LED on the drive ON all the time?
If it is, the drive is toast.

We need to check the binary, we used the stock 4570A version on the L&D site. We’ll pull the file until we can do some more testing.

The flasher is known to work, and 4571A firmware works and has known provenance.

Unfortunately the poor effectiveness of the checksum NEC is using for the 4570A firmware gives rise to the potential for a corrupt firmware appearing valid. We trust L&D as a source and will probably now contact Dee-27 to get a first hand image with our own tools.

Brother Vlad

It looks like something (I guess Ultraedit) corrupted the firmware files. Updated versions have been uploaded to our site now.

Anyone who downloaded a 4570 firmware before should delete the file!

The light is constantly on. I cant get into windows with it connected.

It toast then?

If you don’t have access to an external flashing device and know how to solder and unsolder SMD chips, probably yes.

okay thanks for the help guys

@wiganath
Sorry to hear your drive is dead.

@TDB. Requested file should be in your email inbox :wink:

Bummer i know :frowning: i guess thats what you get if you buy without checking first and then trying to mess with things you don’t understand.

Theres £30 down the pan :frowning:

Can anyone recommend a new one that may work? I’m using Titanium 8x4.7gb DVD-R. I was thinking of staying away from NEC this time and trying a Sony or LG.

There anywhere i can check which drives read which disks?

wiganath, try this just so I know mine is not just a fluke.

I suffered the same fate as you with the NEC ND-4570A firmware, but I think I may have some hope for anyone in our situtation.

I had the drive connected alone on the Secondary Master IDE, and the jumper set to Master. As soon as you start your PC up with the Drive connected the LED on the drive will flash, during these 1-2 seconds I pressed the Eject button a few times until eventually the drive tray ejected and I left it open.
Then the Bios detected the Drive and started up in Windows normally and even detected the Drive in Device Manager.

This may give us the chance to be able to flash the Drive with the correct firmware.

  • But I 've already e-mailed The Dangerous Brothers about this over the last few days, and they have been very helpful and now just waiting on their updated Flasher or DOS Flasher for the Bin files.
  • Clov!s2k3
  • Peter Andersen

IT LIVES… My NEC ND-4570A is Back from the Dead.

After a few hours of playing CoD2 (getting my **** kicked in a funwar), I checked my e-mails and recieved a new reply from Brother Vlad of the The Dangerous Brothers with attached an updated version of the flasher with the correct firmware (Original, RPC2). So I was raring to try it and see if I could get it working again.

I will detail what I did just in case anyone does understand my previous post:

  1. Connect the Drive to the Secondary Master IDE. (Primary has my Hard Drives)
  2. Set the Drive to Cable Select via the jumper on the back of the drive.
  3. Press the power button on, when the Drive powers up the Green LED on the drive will Flasher between 1-2 secs. While or just as it stops, press the EJECT button on the drive between 1-6 times (not sure on exact number as it took a good 20 attempts). The Tray should hopefully eject and then leave it open.
    *If the tray shuts, I don’t think it will be detected and will hang the bios detection.
  4. The Bios will not hang and the screen should detect the Drive as normal e.g. “_NEC ND-4570A 1.02” or whatever.
  5. Windows should start up as normal and the Drive should be listed in the Device manager
  6. I ran the Firmware Flasher from the TDB sent to me (1:05am), Then shutdown the PC.
  7. When I started it back up the Drive was detected and Tray Ejected as normal. I gave a few DVD’s and CD’s a try just to make sure and it seems to be back to normal.

So now wigananth Hopefully you get back that £30 like myself and anyone else in our situation, as long as you have a bit of patience and time.
Also I wonder if this might help others with different models or Manufacturers of Drives in similar problem. :rolleyes:

Unfortunately I can’t upload the firmware myself and I have already e-mailed TDB to say that the Drive seems to be working as normal, so maybe by tomorrow the updated flasher should be uploaded to their site. Unless you guys think more testing should be done?

But thanks to Liggy for the Firmwares, and the Dangerous Brothers for thier Flashers, e-mails and help for getting the problem fixed.

But don’t think that this whole experience has deterred me from making this and any other Drive I buy to RPC1…

Thanks guys

  • Clov!s2k3
  • Peter Andersen

Nice work dude, you may have just saved me buying a new drive.

I have only done the first part, and xp loaded up and i can see it in my system drive.

I got to go to work now, so will try the latter parts when i get in later.

Nice job :slight_smile:

The Dangerous Borthers have uploaded the firmwares (including RPC1) to their site at http://tdb.rpc1.org/#ND4570A

So you should be able to flash the Drive back to it’s original state or make it RPC1, like I now have. :slight_smile:

Good Luck

@ Dee-27, thanks as well. (I missed you out)

You also can use the new binflash 1.26 with the 4570 firmware that can be downloaded from Liggy’s.

Thanks for the heads-up. Now I will have a loader when the next firmware comes.

Many thanks to all especially Clovis2k3 that worked a treat mate and i’m back in business.

I burned a game - Call of Duty 2 on one of my Titanium. I know it works as i’ve tried it on a laptop. However the NEC won’t read it. It doesn’t seem to recognise these blanks, but i somehow managed to burn one of them through Nero 7. Any ideas why?

Clovis2k3 what dvds are you using?

Personnally I use Nero Burning Rom 6.6.1.4, Alcohol 120% or IMGBurn (Depending on what I need it for).

Also here is a list of the discs that I currently have:
DVD-R:
Datawrite Titanium 16x DVD-R (MCC 03RG20)
Ritek 8x DVD-R (Ritek G05)
Panasonic 8x DVD-R (Taiyo Yuden TYG02)

DVD+R:
Bulkpaq 8x DVD+R (PRODISC-R03-003)

DVD-RW:
Verbatim 6x DVD-RW (MKM 01RW6X01)
Maxell 2x DVD-RW (MCC 01RW11n9)

You might find that DVD+R perform better on this drive, but I use DVD-R because I consider them to be more compatible with most standalone DVD Players.
If you have the same discs as me, maybe try writing at a slower speed like 12x or 8x, or try different software like “IMGBurn” or “Alcohol 120%”.
Otherwise if you want disc suggestions maybe look here at the following posts which should be a lot more helpful.

NEC ND-4570A : Post your scans and questions here
http://club.cdfreaks.com/showthread.php?t=167896

NEC ND-4571A : Post your scans and questions here (Basically same drive)
http://club.cdfreaks.com/showthread.php?t=168769

TBH, I not that satisfied with the NEC ND-4570A. I only bought the drive on impulse. I was actually queing up to equire about an ASRock Motherboard (which they didn’t have) and I overheard the person at the counter serving the person in front of me mention “NEC 4570A”. When I got served, I ask whether they had this drive and thought it might be about time to replace my “NEC ND-2510A 2.05C” (Liggy/Dee Modified firmware :wink: , then give this to a friend of mine), and maybe it will be better at the Ritek Discs than my “BenQ DW1640 BSOB” (RPC1 TDB Firmware :wink: ).

I only managed to use the Drive a few times in the week it was working. But I managed to burn a few discs that had a terrible scan in “Nero CD-DVD Speed 4.11”. (Maybe it’s just me :confused: )
Personnally I hope that a new firmware will be released by NEC or whoever to improve the writing of this drive, especially on DVD-R.

Hope this helps

  • Clov!s

“There are only 10 types of people in the world: Those who understand binary, and those who don’t”


Is this thing working 100 %?? Something is obviously wrong, is it the disc? do i need to change something??

I have no idead with dvds :eek:

Is this a blank disc your trying to scan?
Cos the whole purpose of this program is to check how well a disc was written.

If you want to check the media code of a disc maybe use:
DVD Identifier http://dvd.identifier.cdfreaks.com/
DVDInfo http://www.dvd-recordable.org/wwwimgs/media/flash/dvdinfopro/index.htm

Okay so if i insert the blank disc it takes an age for anything to repond, eventually this little box pops up, maybe after a minute and allows me to pick what i want to do. i.e, open , burn data cd etc.

If i try and burn a data dvd its spits out the dvd and tells me to input a blank c.d.

Question - Did i need to do anything to set this dvd up properly? I didn’t get any c.d’s or booklets etc with it. It just came in a plastic style bag and i plugged it in where my cd writer was. I haven’t changed anything in bios or windows. I just assumed it would plug in and work.

Have i just got bad dvd’s or a bad writer?