NEC 3550A DVD Drive Gone Mad

I was using Virtual Clone Drive 5.1.1.1 to try to open .iso files. The software kepty crashing my machine no matter what I did so I uninstalled it. During the uninstall my machine locked up and I had to reboot it. Once I logged back in I one of DVD decrypters, DVD43 complained about not finding the DVD drive. So I looked in My Computer and sure enough the DVD drive was nowhere to be found. I went into the Control Panel -> System -> Hardware manager and noticed Windows XP had flagged the DVD drive as “Not working properly”. I checked the IDE and power cables, no problems there. I removed and readded the drive and that did not work. I can’t up date the firmware or drivers. I get “Target NEC ND-3550A is not found correctly”. Is there anything I can do to recover my drive. It was not expensive but I would like to recover it.

Thanks

I wouldnt try to update any firmware until your drive is properly installed. If your drive is not on the same IDE channel as the operating system hard drive you can try to go into the device manager under ATA/ATAPI controllers and uninstall the IDE channel that the 3550A is on, then restart your PC, Windows will reinstall the drive. If the hard drive is on the same IDE channel as the hard drive don’t do it as we don’t know your system. Some PC specs would help. Let us know.:slight_smile:

Sorry, I shouldve provide more system info. I am just frustrated atm.
I have an ASUS A7V8X-X mobo , Athlon XP 3000, 1GB RAM, 40 GB HD, I am running Windows XP HomeEdition SP2, and I have an NEC ND-3550A DVD CD Drive.

Crossg,
After some research I tried what you recommended and that did not work. Windows is say that the drivers for the device are either missing or corrupted. The NEC website is no help, all they have are firmware updates and the MS website is just as bad only there are no NEC updates at all for the 3550A.

Any help anyone can provide will be much much appreciated.

Hmmm. Can you do a system restore to before you installed Virtual Clone Drive 5.1.1.1. By the sounds of it this app did something to the Windows IDE drivers. Just taking a shot in the dark.:wink:

Well, after a bit more digging I fixed the problem.

Some people on another board were having a similar problem and someone posted this link:
http://support.microsoft.com/default.aspx?scid=kb;en-us;320553

This worked perfectly and my drive is back to normal!!

:bigsmile:

Hell yeah! :wink: