NEC 3550A Burning Problem

OK, so I bought NEC 3550A a week ago.
The problem is that if i burn 4.3gb with nero at 12x, nero shows remaining time about 6:30minutes. But instead, it takes about 12 minutes to burn at 12x. Also the used read buffer moves from 0~98% all the time. I used TY02 (made in japan) media for this.
I thought it could be a DVD media problem, so i tried it with other ones such as optodisc08, at 8x, and i had the same problem. it takes about 3 minutes longer to burn than it shows on nero.
I even tried updating firmware again, but it did not fix this problem.
anyone know why this is happening?
thanks!

It’s happening because it’s a Nero problem. Furthermore that time info cannot be correct because Nero doesn’t know different write strategies like CLV and CAV.
If you burn a DVD faster than 4x, the drive starts burning at 4x but shifts up later to 6x, 8x, 12x and even 16x if you burn at 16x.

There should be a fix on the Nero site to show you the real speed when burning, but the time info will not be corrected, AFAIK.