NEC 3550 doesn't see original Movie DVD

Hi all!

My two NECs ND-3550A doesn’t see any original DVD on my computer (after ejecting DVD I can’t do anything on computer, computer is unusable, I must reset it), but old NEC 2500A see them and it’s ok. With DVD+/-R there aren’t problems.

On other computer they work ok.

Firmware of 3550: 1.05
My computer: motherboard ASRock P4V88+, Celeron 2GHz, 768MB RAM, Sapphire 9600PRO video, Maxtor 40GB IDE HDD.

Any suggestions???

I have the same problem with my 3550A,it would read CDs but wont read any DVDs,burnt DVDs or Original…and I have to hard reboot also after I put the DVD in becauses it freezes everything,I tried it on a Laptop using an external case and 2 Desktops using it internally,no Luck…a buddy of mines bought his own the same day i bought mines and he has the same problem,I dont know whats going on with NEC…

This is something I never do because, for some reason, Windows Media Player won’t play DVD Video. I just get an error. However, seeing this, I thought I would try to replicate it on my Windows XP SP2 system. I insert a store-bought DVD movie, Windows does an auto-run and asks me what to do. I tell it to play using Media Player. Media Player starts up, I get my error message, but no freeze up or other bad behavior. So this may not be typical of all 3550’s (I hope not).

Use a real dvd software player and don’t try to access the media using buggy exploder or wmp…

What software is that then?

I use WinDVD for movie watching.

After last firmware updating (1Y5 from this site) only 1 DVD don’t read at all. But now I’am not sure that I want to buy one more NEC-3550 or ND-4550 :frowning:

I prefer PowerDVD over WinDVD because the latter one has some issues with some Regioncode Free patches and software…

But try with VLC tool, which is powerful and available for free. :wink:

I am bringing this thread back to life because I have tried everything and I have the same problem these guys did. Firmware version 1.6. I’ve tried regionless firmware, and software to make my dvd drive regionless. and I get the same problems with not loading any dvd’s. I have found that most older dvd’s will load but none of the four dvd’s I rented (just to watch with my surround sound) won’t play. The movie I own Driven will also not load. All of these DVD’s seem to be DL dvd’s from what I’ve found on the back of the dvd case they came in. It is the same NEC ND-3550A. Anyone have any idea’s? I am about ready to buy a new burner!

I’m having exactly the same problem, also tried many players, powerDVD, VLC, windows media player classic, mplayer, windows media player 9.
Also installed ffdshow, but that didn’t seem to help either.
Sometimes a DVD doesn’t play at all, sometimes the menu is reached, sometimes it even plays,…but it then freezes immediately.
These are all original DVD’s.

Clean the drive.

Another thread dug up from the grave about the ND-3550A problem. In the last 24 hours I’ve read at least 30 separate posts about this same problem on this particular drive. It sure doesn’t seem like coincidence to me. On one forum they said if they moved the drive to a PC with a different motherboard chipset it could read the same DVDs it couldn’t read in the original PC. Reinstalling Windows on the original PC didn’t fix the problem.

Anyway I have the same problem, bought this drive a week ago and when I burn a DVD on some brands of media then try to read it back the drive sits there reading the disc for about 2-3 minutes, then finally the drive label in explorer changes from “DVD-RW Drive” to “CD Drive” (instead of showing the label on the DVD) and the disc doesn’t show any files even though it might be full. The software you use has nothing to do with the problem as far as I can tell because the drive itself can’t even read those discs. I’ve tried 3 different burning programs and 3 different firmwares. The same DVD plays fine in my dvd player and other drives.

It looks to me like the drive thinks certain discs are CDs instead of DVDs and it’s all downhill from there. I’ve put in an RMA request for this drive, so if I can’t find a solution in the next few days I’ll be returning it for a drive that acts normal.

Nope, CDs and DVDs are definitely recognized as CDs or DVDs.
That info can only be faked by some 3rd party softwares running in the background…

Sorry chef, but I have no idea what you’re trying to say there. The fact that the drive label changes to “CD Drive” when a DVD is in the drive, and back to “DVD-RW Drive” soon as you eject makes it look like it’s assuming the DVDs are CD-ROMs.

I got my RMA# so I have until Monday to play around with this 3550A before deciding to return it. I just burned a DVD5 iso movie onto Sony 16x DVD+R media. The drive burned it no problem, but still has a little trouble reading the disc at first, but then finally appears to load it fine, but when I try to play the movie using any software, it just hangs up and can’t read the disc. If I go to the video_ts directory it shows the file list no problem, but when I try to copy some of the vobs from the disc I get the attached crc error. A few of the vobs start to copy but then it has trouble reading the files and eventually stalls for long periods. I tried the same disc in my dvd player and it plays just dandy. Again it seems to have burned the disc okay, just can’t read it back.


I was curious what nero speed would show for the Sony 16x +R burn I mentioned in my last message. I haven’t done any of these tests in over a year, but does this look horrible or what?


I switched the secondary controller to PIO mode and it was able to read the Sony D21 disc. I was actually able to play the movie in Media Player Classic but it had problems still with certain spots. It still won’t read the Ritek DL disc I burned with the same drive, so I’m switching back to DMA.

I also installed ASPI 4.71 to see if that would change anything. It didn’t.

Here’s something to add to this mystery. I took my burned DVDs to a friend that has a fairly new Dell PC with a 16x burner (not sure what brand yet, Nero just reports HL* something) and a DVD-ROM drive. He couldn’t read any of my discs, but I had him burn a DVD using my Sony media and his burner couldn’t read it either. Then I had him try reading his own burned DVDs (TDK, Memorex, etc) in his burner and it has the same problem, can’t read them. His DVD-ROM drive on the other hand reads all his discs, including mine. I took a couple of the discs he couldn’t read home and my NEC can read and play them fine. He never noticed his burner didn’t read his discs because he always uses his DVD-ROM drive for reading/playing.

Since he has the same issue on a fairly new PC with a different burner, I am now wondering if Nero or some other software is causing a conflict. When his burner couldn’t read the DVDs it did the same thing mine did where it changed the drive label in explorer to “CD Drive” instead of showing the disc label.

This is my first post here. I JUST found out that my 3550 plays olderish dvd’s, but not new ones. I just placed in a new dvd and it froze the system, actually more like VLC wouldn’t do anything and I was force to shutdown.

The drive seems to burn fine, although I haven’t really done any movies, except for one that was an iso, and I watched that in my standalone player also music cd’s and backup data dvd r’s seem okay.

Man, I’ve been googling like crazy to see if anyone has had this experience and I’m kinda mad right now cause I guess I’m realizing that this 3550a is crap! And I guess I can’t return it because it’s been maybe 9 months since I bought it. What really makes me upset is I tested the drive using older movies and was basically fooled. And yet most of the reviews at newegg are pretty damn positive about it.

Well before you toss it, read both pages in this thread from this guy “George Valkov”:
http://www.helpfeeds.com/showthread.php?t=427423

Someone had a similar problem and his advice seemed to have fixed it. The main thing I’d try is removing all unsigned drivers from the driver details of the drive in question. This didn’t help my 3550A, but it might help you.

From my 2 weeks of screwing around with this drive, my opinion is that new or old media is irrelevant. It’s good and bad media. My drive can’t read stuff it burns on bad media and it can’t read other people’s stuff on bad media. But anything on good media it can read. Mine wouldn’t read Ritek SL or DL media at all, sometimes I could get the disc info, but it would never read the data or video on the disc or even show the files. TDK taiwan media it had a problem with, but could read it, badly. TY and Fuji (TY) media works great. Sony (Taiwan) media had problems but it would work sometimes.

Now, some people on this forum would say, “So what’s the problem? Just use good media.” But the problem is, not everyone I know uses good media, and I don’t want to be stuck with a drive that can’t read bad media, when even my crappy old dvd player can read it.

That is just a stupid explorer bug…