NEC 3540a not reading cd roms, reads dvds

Hi everyone, I just got a 3540a for my girlfriend as her primary optical drive since I’ve read nothing but good things about it on fatwallet. Anyway, after installing with a fresh install of win xp pro, it will not read cds. But I know it reads cd’s because I used the drive to install the copy of windows that is on the hard drive.

So here is what happens, When I insert a cd, computer takes a long time trying to process it, but nothing shows up. When I double click on the drive icon, drive light stays on and system hangs a bit and then it opens up a windows with nothing in it. What do you guys think the problem might be? Thanks in Advance.

Check to make sure the drive is in UDMA 2 mode.

thanks for reply, I checked the device manager. The drive is on secondary master right now, nothing on slave, it shows the current transfer mode is UDMA 2. Could it be some kind of hardware ide issue?

What about the jumper? Is it set to master? Not installed? Did you try the way? What is the mobo and chipset? Is autoplay on or off? If you press refresh in Explorer does the CD show in the drive?

hey thanks again for helping.

Here is what I tried. The jumper on the drive initially was on master, so I changed it to cableselect. Same thing happened. I thought, ok maybe it is ide cable that is bad because it was an older cable, caused weird problems to this computer before, but anyway, so I put the drive on primary slave, same thing is happening. I tried refreshing it doesn’t do anything. Once the drive stops trying to read when I try refresh it doesn’t try again.

The motherboard is an ECS k7s5a (not the pro) with the sis 735 chipset. This was a fry’s weekly special a while back. Autoplay is on prompt…

I just tried booting into safe mode, and see if it’ll read it. When cd is inserted it hangs a while, nec drive light stays on entire time, and then once its done hanging, I double click on the drive icon, it tells me to insert a cd.

I am running xp pro xp2

Did you try to take the jumper off completely? I know it sounds like grasping for straws, but there was another thread like this in the NEC forum.

I just tried removing the jumper completely and put it back on to secondary master…still no luck, when I insert blank dvd, it takes a second to recognize and then autoplay comes on and ask what I want do with it. although it say its a cd or something, but in nero it recognizes dvd with no problem…could you please direct me to that forum? I tried searching prior to posting and didn’t yield any good results, thanks again

What happens when you insert an audio CD?

Is InCD or DLA installed?

You might just have a bad drive. I bought a 3540A from newegg.com back in July and it worked great for about a month. Then it stopped reading CDs. These combo drives have different lasers for CD and DVD and I think the laser just burnt up. So I got a replacement RMA from newegg and got a new 3540A earlier this month. It worked great for about a week and then the same thing happened. Stopped reading CDs. Still burned/read DVDs just fine. So I sent it back and they are going to replace that one. I hope the 3rd one holds up because I really love the drive but I don’t want some busted piece of junk that can’t read CDs :doh:

I saw something like this kind of weird thing in WinXP once…
Try booting from your CD with WinXP cd in drive. If it will boot up… it is software issue. If it boots into windows, then your drive is toast.
Remember booting off the CD when you installed winxp? This bypasses the OS and will be like when your system was prestine. Give it a whack! Then you will have divided the problem in half with hardware or software anyway… hope that helps! XP has some built-in burning software from hell in it… tends to hang up on some CD burners for some weird reason.
Also, laser is different (wavelengths) on DVDs than CDs. Laser might be weak on the CD emitter side… or dirty… (you’d be suprised!). If it does not boot into XP load from the CD, try cleaning with a little cotton ball on a stick.
I hope this works for you…
Stan

I had the same case on my laptop combo drive - it could read any DVD media, even boot from it, could write CD-RW, but could do nothing with CDs.

So, here’s an alternative tip of the same kind as the previous one, just to be sure.
Or instead of it, if something don’t work for you:

  1. Get a CD in which you 100% sure that it is OK, better a pressed CD-ROM.
  2. Insert this CD into a drive and watch carefully both CD and hard drive LED (indicators), just count the blinks and time. Eject CD and repeat a couple of times so that you can remember the pattern.
  3. Turn the CD over (insert it with printed side down) and repeat the same. If you don’t see any difference in CD indicator blinking, than it’s 99% a hardware issue - the drive just can’t read the disc.
  4. If the picture is different, it’s 99% you have some kind of a software conflict. Drivers, BIOS settings, CD caching software, (like DVDidle), antivirus, anything. Then you have to check it works with other system or clean system, or try the advice from the previous post.

Service people told me that there are several lasers in these drives, and if the one responsible for CD reading is gone, the picture is as described. I used this tip to prove at service center that I have hardware case, not my software configuration problems, and I was lucky to replace my drive by warranty.

Hope it can be helpful for you or anyone else.

I had similar problems with same device. Problem was that NEC was on same IDE channel as my hard disk. Apparently, problem was that disk was using UDMA-66/100/133, and NEC was using UDMA-33. Leaving NEC alone on that IDE channel solved the problems.

seems like it is all nec drives issue.
my 3520 after ~4 month of exellent work stopped reading cd’s
in the place where i bought they replaced it with new 3540
i hoped it was only 3520’s problem, but now i see it wasn’t

Today I started to have that problem too :frowning: Cannot read CD but read/write DVDs.It is at UDMA 33 mode and secondary master. I havent started to play with jumpers and so but I dont have any hope on these. I am going to call them to change. Any of you knows how to fix that at home? Actually I dont have time to send and wait them to send new one back…

Same problem here with 3540A. It doesn’t read anything at all :frowning:

It hasn’t much use and I bought it a few months ago.

Very same problem here. My NEC reads DVDs (not even all) and cant open CDs. Maybe it’s possible to fix it with a lens cleaning cd? I see alot of people have this problem with NEC drives.

Same issue here - my 3540A worked great for over a year, one day it won’t recongnize data CD’s or music CD’s - even commercialy pressed ones. When I instert a CD-ROM it just clicks 10 times over the span of 30 seconds or so. . . tried Xata’s flipping the CD over trick and the drive makes the same noise both times.

I don’t think I’ll be replacing this drive with another NEC drive.