Nec 3540a - DMA/PIO Help

vbimport

#1

Hi! I’m in desperate need for some help. Here’s what’s going on…

I’ve recently installed a NEC 3540a burner (using L&D’s 1.W5 firmware.) My drive will not work in DMA mode (it stays in PIO) – UNLESS I have IAA installed. Then it works fine. Except, when I have IAA installed, I can no longer defrag or do any kind of spyware scan without my whole system locking up on me.

My drive is installed as the master on my Secondary IDE channel. My regular DVD-Rom drive is the slave on the Secondary – and it’s set as DMA all the time. No problems there.

I’ve tried all the suggestions from every thread on the web. Uninstalled the IDE channels, changing the registry, toggling pio to dma and back and forth. None of it has worked except for IAA – which, as I said, leads to other problems that are even bigger.

Any ideas? This is driving me nuts! Thanks in advance for any help!!!

P.S. My system is a HP Pavilion 7955 running on Windows XP SP2. I’m kind of a newbie when it comes to this stuff, so don’t kill me if I left out any other important info. :slight_smile:


#2

Have you checked your Bios for the secondary Ide Channel set to DMA?


#3

ok lets try a few things…1st remove the second device on that channel and try the dvd burner alone on that channel…sometimes you need to move things around to get them all happy together.you may need to change the position of the devices to get them all working with the HP bios.


#4

As far as I know, I can’t specifically set the bios to DMA. It’s set to AUTO with configs for both DMA and PIO in the bios.

Rivi, when you say remove the second device – do you mean from device manager, or physically from the cable?

I guess my next question, if I can never get this working, would be, does anyone know why IAA would be causing problems with defrag? Like I said, it does force my burner into DMA and works like a charm. But all the other bad stuff that comes along with it makes it not worth it. :slight_smile:


#5

When you don’t use IAA, what drivers are reported in the device manager for each IDE channel? (device manager > IDE controllers > whatever channel > properties > drivers)


#6

When I don’t use IAA, it’s running Microsoft, version 5.1.2600.2180. Dated 7/1/01.

Under driver details it lists, C:\windows\system32\drivers\atapi.sys and C:\windows\system32\storprop.dll


#7

OK :slight_smile:

Check the model of your motherboard if possible. It sounds like an issue with the IDE controllers of this mobo. Maybe a BIOS update could help, but first thing to do is google a little with you mobo model + “IDE”. Maybe you’ll find related comments…