NEC 3540A can't write DVD+RW

I’m trying to write a Fedora 9 ISO to a DVD+RW using Nero 8 with my NEC 3540A writer but it fails every time I’ve tried no matter the options I choose in Nero.

I borrowed a friend’s external Sony drive and was able to write the disc without any issues. I’ve also tried swapping a BenQ drive and get the same error message. I have tried writing at different speeds to no avail.

I only get this issue when I use these DVD+RW. DVD+/-R SL work fine, but I want to use these DVD+RW for the Fedora image. I use mostly Verbatim discs, but have some Fuji discs which are mostly rebranded TY but also a few rebranded Riteks. CD-R and RW discs work fine almost regardless of brand even though I have 90% Fuji branded TY CD-R and a few Verbatim 10x CD-RW. Memorex discs, however, have yielded consistently poor results.

Media is Verbatim 8x DVD+RW SL

System is running WinXP SP2
No overclocking
Intel Core 2 Duo E6600
2GB RAM
HDD is Seagate SATA + 2 PATA, WD and Seagate on separate channels, on a PCI based PATA card
DVD drive is the NEC 3540A on PATA by itself with Dee’s 1WB fast firmware

I keep getting this error message in the Nero log file:

6:50:50 PM    #2 SPTI -1080 File SCSIPassThrough.cpp, Line 196
    CdRom2: SCSIStatus(x02) WinError(0) NeroError(-1080)
    CDB Data:   0x51 00 00 00 00 00 00 00 20 00 00 00 
    Sense Key:  0x02 (KEY_NOT_READY)
    Sense Code: 0x3A
    Sense Qual: 0x00
    Sense Area: 0x70 00 02 00 00 00 00 0A 00 00 00 00 3A 
    Buffer x04b9e700: Len x20