NEC 3540 Cannot change Secondary IDE Channel properties

If anyone has any suggestions that could help me I would be grateful
My 3540A not writing at full speed .I checked the IDE channel properties.

Secondary IDE Channel properties

Device 0 transfer mode: DMA if available
Current transfer mode: Ultra DMA Mode 2
Device 1 transfer mode: DMA if available
Current transfer mode: Not applicable

Device1 Is the Nec 3540 I have tried to change the transfer mode properties with no success. any ideas would be great,

                                 Thanks,
                                          Angelony

Try right clicking on the ide channel the NEC is present on and choose uninstall. Exit the device manager and reboot. Go back in and check again.

If that didn’t work try going into device manger and select DVD/CD Rom Drives, right click on the NEC 3540A and choose uninstall, once again reboot and check if the DMA is now set to Ultra DMA Mode 2.

Uninstalled Secondary IDE Channel and rebooted. Worked like a charm
Thanks itzbinnice

Glad to hear that, wish all the problems were that easy.
Good luck with your burning, any problems post back.