NEC 3520A Problem after install

vbimport

#1

Here’s my old problem posted in another forum:

Last night I replaced my old LG burner with a new NEC 3520A from Newegg. I connected it up as secondary master in the exact config as my old LG (secondary slave is my Maxtor 200GB). First boot Windows took about three minutes to boot (normally about a minute), and the drive wasn’t even recognized. I rebooted, this time viewing the post screen, and the bios detected the drive. Then once in Windows it found the new drive, and it worked fine to burn my first DVD. Then this evening I started my machine again, and same problem; long boot time and no burner. Every time I reboot now I get a long boot time, and sometimes Windows detects the drive, sometimes not. It is detected by the bios for every boot however. Any help on how to fix the boot & detection problem would be greatly appreciated.

Now on to my new problem:

Alright, I have solved my problem by switching the way my new burner was connected. I switched it with my LG combo drive so my new NEC was set to primary master with no slave attached. As stated this fixed the slow boot times, and Windows will recognize the drive every time, however I now have another problem.

When I burn a DVD the DVD’s buffer “jumps” all over the place. It jumps from 100% down to 9%, back to 90%, down to 20% during the entire burn. Also the burn speed says it will burn 8x but it takes about 30 for a full burn. That ends up calculating to about 2x. Once again any help is appreciated.

Operating System: XP Pro SP2
CPU Speed: AMD 64 3700
Harddrive space: WD 74GB Raptor, Seagate 200GB
RAM Memory: 2048mb
Video Card: RADEON X800 XT Platinum
Motherboard: DFI Lanparty NF3 250gb
CD Writer: LG 4480 48x24x48 DVD Combo firm 1.00
DVD Writer: NEC ND-3520A firm 1.04


#2

Sounds to me like your drive is in PIO mode vs UDMA. Maybe set your drive for Auto detect in Bios and check your device manager to see if your drive is in UDMA 2 after reboot. :slight_smile:


#3

I found where to change to DMA mode, but it is giving me many options:

Ultra DMA 2 - Ultra33
Ultra DMA 1
Ultra DMA 0
Multi-word DMA 2
Multi-work DMA 1
Multi-work DMA 0
PIO Mode

I tried selecting Ultra DMA 2 - Ultra33 and burning and I got a improvement in speed and the buffer stayed at 97% more often then before, but it still jumped from time to time. Especially towards the end of the burn. The total burn time is down to about 14 mins which is still only about 4x. Is Ultra DMA 2 - Ultra33 the correct choice or should I try another?


#4

Sounds like its not set for Ultra DMA mode 2. Was the master/slave jumper set correctly as a slave? Try a high quality 80pin EIDE cable. That motherboard’s IDE controller and/or driver may have some compatability issues - see if their are driver updates for XP available.

Normal 8x burns, start at 4x, then move up to 6x, then 8x for the last half of the disc. A full 4.37GB burn at 8x takes about 10min - 14min is about 6x average. What is the media? If its a lower quality it might be slowing down at the end due to media. Use high quality media like 8x DVD+R from FujiFilm or Verbatim. Its normal for the NEC’s buffer to move down a bit at times during burns, as long as it only does it for a short time and jumps back up its fine. Ultra DMA mode 2 (33Mhz) is the fastest speed that the NEC supports - thats what you want.


#5

Disregard. Verybadboy answered and I can’t delete. :wink:


#6

It seems that it didn’t like being on the same IDE cable as the hard drive. I moved it to the master the cable with my LG drive, and boot times are good and burning speed is 10-11 mins. Shame it only took me four hours of plugging cables to figure it out. I thank you all for your help.


#7

Yes, mixing a hard drive and optical drive on the same channel is never recommended.


#8

Just got a NEC 3520a to go along with my Liteon 1653s. My question is does it matter which drive is master and slave? I don’t really plan to use one drive more then the other so will having one set as slave hurt performance?


#9

ttt


#10

I’ve never found it made any difference, if it works don’t try and fix it. :slight_smile: