Nec 3520A doesn't work in usb2 ext. case

vbimport

#1

I’ve bought a nec 3520a dvdburner because my liteon dvdburner went broken. I use the nec burner in combination with an extern usb2 case (ICY BOY link )
Problem is that the nec doesn’t work in that case, windows recognise the burner but i can’t read, write,… with it.
My liteon worked perfect in that case, also an hd, cdromdrive is no problem.
The nec isn’t broken because it works perfect when it’s connect directly to the mainboard with an ide cable, but because i use a laptop i need to connect it to usb2…

Someone knows how i can solve this problem? I’ve allready tryed to change jumper settings etc… no conflicts with other usb devices.
The usb case has an Ali chipset, maybe it’s not compatible with it ?


#2

Same thing here with Ali chip based USB external case ( Bytec ) . It reads & writes CD fine but will not write DVD ( NEC or Pioneer ). Went ahead with Nero upgrade etc. but still no go .

I then bought a Prolific based chip (Plumax ) and it works fine with both NEC 2500 and Pioneer A08 . I think Ali chip is just not very compatible with NEC or Pioneer DVD burner .


#3

I just got a case here:

http://www.akida.net/.sc/ms/dd/1111278668514972/0/nc/Computer%20Hardware--Mobile%20Rack%20^2F%20Enclosure/182/Enclosure%205.25%26quot%3B%20ME-320U2F%20USB2.0^2F1394%20Combo%20(Retail)

and it has the Prolific chipset and works on my NEC 3500.

Are you sure you have your jumper set to master?


#4

thx for respond, i’ve tried master, slave and cableselect.


#5

Have you tried burning to DVD+R discs? Or DVD-R if you already tried the +R’s. Perhaps it is something like that. What error do you get?


#6

The drive just don’t work, can’t read any cd/dvd or write anything.
The led stays on also when there’s no media inserted.


#7

that’s odd. I have one of these ALi chipset enclosures and it works fine with my 2510 and my 3500. I have the drive set to MA and I’m using an 80 pin IDE cable.


#8

Hmm, i think i’ve found the problem. The Ali chipset is not the problem of the usb2 case, but the power supply is to weak?
I tested this with an old AT powersupply, connected to the nec drive. The ide cable connected with the usb2 case and power for the controller and it works now :slight_smile: So the powersupply that came with the external case is to weak or this drive uses more than others :slight_smile: On the powersup 12V/5V 2A, the ATpowersup is 200W. hmz