NEC 3520 vs. Liteon 1673

vbimport

#1

Hi, I currently own Liteon 1633. For the life of me it uses PIO4 so I see 70% CPU utilization (dual PIII 1Ghz each) - I’ve tried everything to change that to UDMA2, trust me but can’t !. I was waiting for 1673 and bought 1633 as a temp solution. Now I hear some people say dump Liteon go with NEC. Can anybody tell me if NEC is much better and what are pros and cons going one way or the other. Many thanks !


#2

Forgot to mention that Liteon is at latest firmware. Thanks


#3

If you system refuses to recognize all drives in DMA mode, then switching to an NEC is not going to help.


#4

You might check to make sure your cable is 80 pin rather than 40. I am not sure it would make a difference, but I do know some drives are touchy on this.


#5

I’ve used 3 different 80 pin cables with similar results. I do not think my system refused recognise UDMA2 devices. Currently I use SCSI 160 on HDD config. So my E-IDE controller is dedicated only to Liteon. I’ve attempted to shift from controller A to controller B same story - PIO4 mode only :frowning: I guess it might be faulty drive… so if I were to swap drives should I go with NEC or Liteon ? I like the fact that there are many tools available for Liteon but reliability issues alarm me… thanks


#6

so, anybody can advice which burner to buy next ? give it a try 1673 or just go with 3520 ?

Thanks


#7

Suspect the problem is with another application in the PC, a bad install of Windows, or a bad motherboard/IDE cable. I would wipe the hard drive, reload windows with the 1633 drive. If you still see PIO, then you may have an IDE controller problem or a bad IDE cable.


#8

I own both. NEC burns all the middle and high quality media I get with a flawless burn. As far as I am concerned there is no question; buy the NEC. Liteon doesn’t seem to have improved their 16X burners while NEC, Pioneer, and BenQ did. Keep the Liteon for scans.


#9

thanx chas ! i guess i’ll go w/NEC


#10

is there a way to copy dvds on the fly for instance Liteon reading (ripping) dvd while NEC recording ?


#11

On the fly is not recommended. If the source drive must slow down to read a DVD, then you have a coaster.


#12

Depending on what software you are using (particularlly if you are using anydvd) it can still be handy to read with one drive and burn with the other.


#13

Ok, NEC has arrived. After install same thing PIO4 transfer mode only. Poked arround in my BIOS (I run Tyan serverboard Thunder HEsl S2567 dual PIII 1 Ghz each with GIG of RAM) and found MWDMA-2 (multiword DMA-2). To whatever reason UDMA-2 can not be selected. Drive reports to BIOS capability of transferring data at UDMA-2 (80 pin cable installed) but as soon as I select UDMA-2 it transfers to PIO4 only. So I stick with MWDMA-2. Thanks to everybody who jumped in with suggestions. I guess I should look into upgrading to a newer board.


#14

Yo-

Ain’t that a bitch after all that-

Hopefully things go better for you with a motherboard upgrade-

Mike


#15

apparently PIO4 and MWDMA-2 has same transfer rate of 16.6 MB. Is that sufficient to burn DVDs without errors ?


#16

now I am for another quest finding decent mobo ? I understand that this forum is for CD/DVD questions but was hoping that somebody can share their positive experience about mobo. I am hoping to go with P4 3.2 EE and dual channel DDR2 memory. Any suggestions ? Many thanx !


#17

Have you tried to uninstall the IDE channels in Device Manager and restart the system so they get clean install? There is sticky and several posts about getting UDMA in Windows. I still have one very old 5X DVD-ROM, it is PIO4 in the BIOS, but in Windows it is MultiWord mode 2, which is not so bad. You should be on UDMA in your case. I have 6 years old motherboard and 40 pin ribbon. The NEC 3500 is the master on this secondary channel working at UDMA mode 2.


#18

yep, tried uninstalling prime, secondary controllers with no luck. On reboot everything goes to PIO4. I think that the Southbridge can not controll correcly EIDE interface. I guess it is time to upgrade motherboard/processor. Any suggestion on what type of the mobo to get. I think I wanna be in 3.2 Ghz realm.