Nec 3520 read speed sucks

vbimport

#1

Hi there,

I’m new to this forum, and spend most of the afternoon reading about the 3500 and 3520 and firmware updates and stuff…

I bought the NEC 3520 last week, and apart from the problem, that it burned DVDs only with 4x (which I hope I resolved by updating the firmware to the beta2, but haven’t yet tried it),

my burner READS dvds (burnt just as originals) only with 1.3x :Z

I d/led Nero CD-DVD Speed and that’s what it looked like after testing the speed with a brandnew original DVD.

Does anyone know why? It should read with 16x, at least after the firmware update.
Even without that update, from what I read the speed should be about 4x-5x

and if I was too stupid and didnt see this was already discussed and solved, please delete this thread after telling me where the answer hides :slight_smile:

a 1000 thanks in advance,

AlleyJazz

btw: I think this forum rules! :wink:


#2

Welcome to the forum.

Have you enabled DMA.

http://club.cdfreaks.com/showthread.php?t=101616


#3

Hi.

In the meantime I read another post (which was written while I wrote mine) and discovered I didnt have mobo drivers installed. I downloaded them and installed them (GA-7dxr). The IDE-Utility says both hdd and writer are in ultra dma 2(ata 33). I followed your link, but cannot find the DMA settings in my hardware settings, they seem to just not be there. Maybe it’s due to my kind of motherboard.

Now the CD-DVD Speed utility says “Parameter Value Invalid (052602)”, and I did not find out why yet.

BUT a short test with nero tells me now, that it’s finally reading with 4x!

At least that mysteries solved now, though it still should read faster. right now I dont have any more time, but I’ll try more tomorrow.

thanks,

AlleyJazz


#4

Make sure that the drive is not operating in PIO mode; looking at the burst rate you get, it seems suspiciously low - it might be that the interface speed is holding you back. My DVR-108 is running UDMA-4 and bursts at 45MB/s; ND-3520A is UDMA-2 and bursts at 26 MB/s. Speed starts at 7x and rises to 14.5 on a 3.5GB DVD-ROM. CPU usage on the NEC goes 10, 18, 32, 62% respectively. The Pioneer is 81% for all read speeds.

Edit: beat me to it while I was typing - looks like UDMA is OK then?