NEC 3500A stuck in Multi-Word DMA Mode 2

vbimport

#1

As mentioned, I can’t get more than 16.6MB/sec (about 10.5x DVD) read or write from my drive. It’s running on a Silicon Image SiI 0680 Ultra 133 controller. It doesn’t matter if it’s just by itself or with another drive. I am using an 80 pin IDE cable. This utility that came with the controller tells me that my Toshiba SD-R5002 is actually in Ultra DMA Mode 2 (33.3MB/sec) and it’s on the controller too along with a 2500A on the same cable. I had a Toshiba SD-M1802 on the same spot on the cable before the 3500A was there, and it was able to go above 10.5x when reading. I am using Windows 98 SE. I think the IDE cable is ok… what else can I try?


#2

Windows 98 suggests quite an old PC, can you provide some system details?
Have you tried the ND-3500A on your m/boards onboard IDE channels?
Checked for BIOS and driver updates for your Silicon Image controller card?


#3

Hi, i’m using the same SI ATA-133 controller card & it won’t work do UMDA mode 2 with TDK 1616N. (same OEM) No problem with other optical drives thr. I suggest you switch to on-board IDE instead.


#4

and one more thing… dma 2 is what the drive would be. dma 2 is 33 meg/sec and your burner is 22 somthing /sec the only way you would be ata 3 (udma 66) is if you had a hard drive or something similar


#5

Ok! I moved the drive to the controller on board, so that the 3500A is Master and this 120GB ATA 100 HDD is a slave. I can get full 16x speed reads now. Thanks. :slight_smile:


#6

I don’t know but I think I have the same situation. Nec 3500 goes up to 12.5x read speed and then the speed remains constant.

Nero CD DVD speed picture

Nec is single set to primary master on Abit KR7A-Raid (VIA KT266A), 80 pin cable.
W2k, properties are set to Ultra DMA (chosen DMA if available). I have tried to use VIA, M$ and standard IDE ATAPI drivers. Situation is the same.

Has anyone got a solution for the problem?

Thnx!