NEC 3500 pio/dma problems

vbimport

#1

Hi folks,

i got some serious trouble with my “new” NEC 3500 DVD-burner. The drive works only in 5x reading an 1x writing mode. With the help of this forum (thx :smiley: ) i indentified the cause: the drive works in pio-mode. Turning to “autodedect dma” in the IDE-drivers (don’t know what it’s called in english WinXP…) didn’t help, Windows doesn’t recognize that the drive is dma capable. Reinstalled IDE/ATAPI drives maybe 10 times by now. :Z Tried all registry fixes proposed in other threads. Nothing helped…

While booting, the drive is listed in pio4 mode and there are no possibilities to set anything manually for CD/DVD-drives in the BIOS … works all over autodetect. I tried to use different cables and different prim/sec-ma/slv combinations … nothing helped. So i’m out of ideas… :sad:

my config:
Gigabyte GA-7DXR motherboard, AMD 760 chipset
NEC 3500 at primary master with no primary slave with 80pin IDE cable
WinXP prof (stable, no other problems)
no virtual drives
my old CD burner runs in same config in dma2 mode … :bigsmile:

anybody ideas?

thx,
Peter


#2

Is thier not an option to enable dma in your bios (for your ide channels, it won’t say anything about cd/dvd)?


#3

yes there are no settings except autodetect and some adressing-issues for harddisks.

But the BIOS problem could be solved through multiple BIOS resettings. Now the drive is recognized (as it should be) as ATA-33. For a short time even Windows had set it in udma2 mode but the read/write speed remained excactly at 1.45x and heavy cpu usage suggested that windows lied :bigsmile:

After redoing all proposed registry hacks and reinstalling IDE/ATAPI drivers the drive is now (not in BIOS only in win) in pio mode again and can’t be set at udma2.

I’m suspecting now that Windows is the “bad guy” so i’ll have an install-party this evening :iagree: … next (and last) option will be a try in another system


#4

You might try this before reinstalling: http://sniptools.com/vault/getting-back-to-dma-mode-in-windows-xp.htm

Good luck!


#5

Change the cable to a 40 pin and try this reg hack:

Open RegEdit
Find the following KEY:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\ Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.
Under each key, delete all occurences of the following values:

MasterIdDataChecksum
SlaveIdDataChecksum

Reboot the computer. Windows should now redetect DMA settings…


#6

Not to say that you didn’t already check, but are you sure that some of those settings in the bios (like the hard drive settings) didn’t enable or disable dma? If it is a hard drive setting it may effect disk drives too. When I had the problem, windows did lie so it took me three days to figure out. Windows showed that I was running in dma (udma mode 2 like yours was), but I eventually figured out that during startup it was reporting piomode4. I was all pissed off because windows lied, but to be fair to micro crap and that rich bastard bill shit head, when I did a little research I saw one place where pio mode 4 was listed as the same speed as udma mode 2? I’m not 100% sure on that but maybe they are the same setting or compatible? Reguardless, when I enabled dma in the bios, it changed to mode 5 on the computer that was running windows ide drivers and mode 6 for the computer running nvida ide drivers (mode 5, 4 and 2 for the hard drives I think) instead of everything mode 2 and the speed problem was fixed.
Hope some of that information helps some.
Fyi have you checked to see what it reported during startup (if it is like my computer it goes by really quick and you may have to restart several times to see it)?


#7

Hehe yes i’m pretty sure that the BIOS settings are correct now: on startup the harddisks are reporting ATA133 and the DVD-drive ATA33 (you can stop booting right after the beep while the monitor is still blank and changing screen :wink: ). Manual settings for harddisks in the BIOS are for adressing like LBA & co.

I think i’ll try the registry hacks again before big rebirth… not sure if i missed one…

thanks awhile!


#8

So … clean and fresh WinXP prof: Nothing changed. The NEC ist still listed in pio mode at the ide drivers config.

Setting TimingModeAllowed to ff ff ff ff AND deleting MasterIdDataChecksum results in listing the drive in umda2 mode… but in reality the drive runs still in pio mode ( near 100% cpu usage and 1.45x drive speed reading)

BIOS checked and ok, cables and connections swapped and checked, tried other registry hacks as suggested, flashed the drive to 2.19 … nothing worked. My CDRW in combination with the NEC or solo causes absolutely no probs (udma2 from start, normal read/write speed). Hard Disks run in udma5. :a

Got no other ideas…


#9

try the drive in another computer if it works their then you know it has to do with your computer

if it does work on the other computer flip the ides make the drive the primary master and the hard drive the secondary master

what kind of MBD are you using?


#10

the NEC has the same trouble in another computer (pio mode) :sad:

if it does work on the other computer flip the ides make the drive the primary master and the hard drive the secondary master

i think i tried that already

what kind of MBD are you using?

this is my mainboard:

the soutbridge is a VIA 686B with integrated promise raid controller. But the rc is not in use and deactivated. I could try plugging the drive on the raid…?


#11

Hello mates, having the same problem as you Silverstar…And its very annoying.Only burns at 2x all the time…no mather what I try.

Here is what I have tried: Hope someone can also help me.

Have tried different media, and have upgraded the firmware to 2.18.
I have also tried it in another pc, but still the same PIO-mode problem.
And of course I have tried to change the settings in the Device setup.

I have also tried the registry hack mentioned above…

Would be nice with some help here


#12

Mike Shinoda, what are the chances that your motherboard is using the same chipset or same series of chipset as silverstar (AMD 761™ north bridge & VIA 686B south bridge). I’m almost wondering if it is a hardware conflict? If no one else comes up with any good ideas, I would say that it is time to call tech support for your motherboard and or nec tech support to see if it is a hardware issue? Just a thought.


#13

no…Im using the Intel Chipset…

heres my MB : http://www.msicomputer.com/product/p_spec.asp?model=865PE_Neo2-V&class=mb


#14

if it has the same in another computer it is the drive in my opinion. get it rma’d and see what happens


#15

I missed that. You are right, if it does it in two diffrent computers it is probably the drive.


#16

I’ve found another possible solution here:

http://www.pc-experience.de/wbb2/thread.php?threadid=5289&boardid=20&sid=
(in german)

Basically you use the command “set devmgr_show_nonpresent_devices=1” to show all remains of previously installed drives in the device manager and remove them (they could cause the conflict). But this doesn’t work either in my case. :slight_smile:

The test in the other computer was not done by myself, so i’m not sure if it was done correct. I’m still suspecting WinXP because the drive is recognized correctly in BIOS. Two things i’ll try over weekend:

  1. setup a linux (are there any usable speedtest programs under linux available? - i don’t have much knowledge with this :bigsmile: )
  2. test it in a computer with brand new equipment
    3.fling the drive against the next best wall :iagree:

…hmm even 3 possibilities…


#17

I vote for number 3.

I used to be a nonconformist, but that crowd was a bad influence. /.


#18

What are you fucking sick… If your 3500 doesnt work well, please sell it to pipemanid@ a new drive cheap or Ripit@ another 3500 for free.com
Fyi if you do destroy it, please sent detailed pictures (though a 20$ bill might be beter than a smashed drive(I,m willing to trade!!!


#19

I’ll give him $5.00, do I hear 6… going once…going twice…last call… sold to pipemanid for $5.00. Shipping instructions to follow. Nice doing business with you.

Problems are like gifts, it’s better to give than to receive /.


#20

silverstar, Thier are people searching for 3500"s instead of 3520’s. Make sure that it is your drive before you give it up… No matter how bad you want to smash shit, what if something else is wrong and your drive is fine? Call nec, you have a waranty, right? Try to get the problem fixed on the phone, casues otherwise, thay might replace it with a new one (a new 3520 to replace your 3500!!!, not a good deal!!!