NEC 2510a firmware upgrade problem

pls help…
downloaded from NEC and flashed firmware:
nero info showed i had 2.15
so i applied 2.16.
now the dvd drawer does not open,
the light constantly flashes,
and nero info shows the drive as a ND-2100A.
got firmware from an nec site

should i try to flash again from dos? (i used the windows flasher that came with the firmware)

i’m in a heap of trouble now!

Either flash in DOS with The Dangerous Brothers’ flash tool or use the Windows/Linux/Mac command line flashtool in the sticky thread in the NEC forum.

wow, thanks.
the herrie dos flash did not work, but the one from cdfreaks nec forum under windows using command prompt did.
thanks again…

Looks like I could use a little more help… thanks in advance…

First a correction to my last post - Actually it was the Dangerous Bros DOS flash that did not work, but as I said the windows flasher did.

I used the 2510"ORIG" bin file from Dangerous- just trying to get the basics working.

Well, burned a disc ok and it works fine on one player but not on another, and I had no problem results on either player with any media previously (this was memorex DVD-R 4x printable media).

I attempted to attach some screen prints from nero infotool and dvdinfopro of my drive and the media that i burned that’s having trouble playing. Hopefully it is actually attached.

This may be a one-off - bad media or something, but thought I’d check to see if this is a familiar problem or if something is clearly wrong with the firmware flash. I noted another post like this but it referred to bit-settings for DVD+R. This is DVD-R… and I would need a referral to bit setting info if that appears to be the problem. Or I could re-flash with other firmware.

(I just wanted to upgrade the drive to burn ritek G05 DVD-R printables at 8x - I think the recent 2.16 NEC official firmware is supposed to do that…)

Thanks again…



Update:
Appears to be that one disc only… burned 2 more (same media plus verbatim) and they are both OK.

However - another problem I would like any thoughts on…

When I reboot the machine, the drive goes back to nec2100!

I redo the flash and reboot and it’s ok at 2510 again…
but if i reboot again it goes back to 2100 and just flashes!

so everytime i reboot i have to reflash and reboot… (or i will need to reflash prior to every shutdown!)

what would cause the old firmware to be re-applied everytime i reboot? there’s no floppy or cd in the drives…

try the GUI version of Binflash http://binflash.cdfreaks.com/

Will do, thanks.
Do you think that will prevent the drive from going back to the 2100 firmware when I reboot?

on reboots my drive still reverts back to a nec 2100… strange… and annoying!

Yo-

Have you tried flashing with winrar.exe within windows (assuming using XP)?

Mike

Yes I’m using XP and I’m using a windows flasher… I don’t think it’s “winrar” - something like “winflash” I think (I cannot access that machine now).
It flashes great - I reboot and it’s fine - 2510a.
Then on a subsequent reboot it goes back to 2100!

Could you try dumping the firmware again, when the drive identifies itself as a 2100 and compare that file with the binfile you flashed before.

Maybe you should remove your drive from Windows (in the hardware management section) and reboot. It should be recognized and reinstalled during boot. Btw, what does your BIOS report at power-on, 2100 or 2510?

Oh, and forget those ProdiscS03 asap, most prodiscs are real crap. Burn them at the rated speed max. and don’t buy them again.

Backed up (“dumped”) the firmware from when it was reporting as 2100 and also when it reported as 2510a, but how do I compare those to the bin file I used when I intentionally flashed it?

Tried many reboots, in all cases the bios just prior to reboot indicated the same drive as nero infotool indicated - sometimes 2100, sometimes 2510a.

A few times I “uninstalled” the device (using device manager) prior to rebooting. It made no difference. If the reboot was done after a flash to 2510a, the drive came back as a 2510a. Usually on the second reboot it still came up as a 2510a but on 3rd reboot (or sometimes 2nd) it comes up as 2100.

This is not terrible, but it is annoying! (and perplexing!)
Eventually I may try installing it in a different machine and see what that does.

Thanks for your help and any other suggestions are welcome.

As far as the media type goes… The disc that comes up as a ProDisc is a branded Memorex printable 4x dvd-r. They are inexpensive and I’ve had almost no problems with them (1 or 2 duds per 100), but have not burned at greater than rated maximum (4x). Aside from the recent verbatim purchase, I’m more likely to buy ritek G05 next time, and hopefully be able to burn them at 8x with this drive!

Comparing two different firmware files is pretty easy using the ‘fc’ command:

  • Copy the files you want to compare to the same directory
  • Open a dos box (Start->Run…->cmd)
  • Go to the directory where you copied the files
  • Enter the command: fc /b file1 file2

the dumped file from when it was showing as 2510 equals the 2510fast.bin file i flashed from. so that’s ok.
the dumped file from when it was showing as 2100 is different from the 2510fast.bin file… so somehow the firmware is changing on reboots.