NEC 2510a -- Contributing to premature hairloss

vbimport

#1

I purchased my NEC 2510a and have gotten great enjoyment out of it, and though it might not have been the fastest thing on the block but it sure backed up nice large chunks of data and was as reliable as a metronome. :iagree:

Recently a friend says to me, “You know, your drive is capable of burning faster if you flash your firmware.” And so begins my accelerating hairloss. :doh:

I began (logically enough) with the latest firmware from NEC directly. Flashed it, no hitches, glitches or complaints. I proceeded to dump some data to DVD as I’ve done many upon many times and it writes OK. Since I’ve never had a problem with the drive or media or anything I’ve burned, I faithfully assumed everything was A-OK. Alas, since the ROM update, this drive seems to be blind in one eye or something. IT can no longer read any DVD its written previously, or the new the one its writes. The disks read fine on other computers in other DVD burners and drives (alas, the NEC 2510a is the soul drive in my system here), but the drive that wrote them simply can’t read them any more. This began what is now a 4-day session of searching for firmwares and reflashing in the hopes that ONE of them will restore the functionality that I had before listening to my friend instead of adhering to the wisdom, “if it ain’t broke, don’t fix it.” :disagree:

So, I would say, oh well how quirky and install another DVD-ROM drive to read what my NEC 2510a no longer can – but then I consider all the open session disks in which I was collecting data and want to pull out my little remaining hair. I’ll have crap spread all over creation and how elegant THAT would be!

The point at last – if anyone has encountered this problem and knows of a solution I would dance a merry jig to know it.

Since I’m not remotely savvy about firmware, just let me know what information you need and I will try my best to provide it.

Reasons I am not wise:

1: I didn’t note the starting firmware revision number. :rolleyes:

2: I didn’t back up the original firmware before flashing. :sad:

3: In the quest for a solution I’ve tried many firmware variants discussed on various forums on this board… I have no idea if I’ve inadvertantly caused damage (though I’ve followed all instruction to the letter, and never interrupted a flash and have generated no errors - not to mention, the drive still burns disks that any other drive (except itself) can read). :confused:

4: I didn’t throttle my friend the last time I saw him. :a


#2

try 25x0_2.F9_RPC+RL.rar from: http://www.micheldeboer.nl/firmware/

but most likely you disc is not good, whenever you burn a disc you should let the software verify the data, otherwise anything goes!

If you have poor media burn quality you can try one of Herrie’s versions, he’s swapped write strategies that allow a much higher quality burn, www.herrie.org


#3

I just wanted to write exactly the same… :cool:

EDIT:
You can verify your data with Nero CD/DVD Speed.
Put your burnd DVD into a DVD-Rom and make a “transfer rate test”.


#4

Still no joy.

I applied the suggested firmware successfully using NecWinFlash, then rebooted as suggested. It’s still unable to read any of the disks its written (either before or after this fiasco began). It does read CDs and actual movie DVDs with no problem. However, data DVDs spin up, and in “My Computer” the DVD/RW designation switches to CD. When you try to explore the disk, it opens but appears as empty.

(I place the same disk in my laptop’s DVD drive and it reads them no-sweat. It’s a mad house! a mad house!)

In fact, now it acts if the inserted disks are blank, and gives me the insert option of burning to them… so on a whim I opened my burner software to see how it viewed the disk… answer: a full, yet writable disk.


#5

try uninstalling your secondary ide controller, in the device manager, follow with a reboot (only for win xp).


#6

I uninstalled the secondary ide controller, and now it can’t reinstall them (driver not intended for platform). To try to get them reinstalled, I’ve tried it in safe mode, I’ve tried flushing my bio settings, I’ve tried the administrator account in both regular and safe mode. This just KEEPS getting better.

So now, I’ve lost all burning functionality… can’t back up my data to try a reformat. GRRR.

I have a solution. Anyone have a sledge hammer?


#7

Well, your drive probably needs a cleaning. I’d say if it’s having trouble reading any of the DVDs that read OK on other drives, and read OK before on that drive, it’s probably dirty. One of those cheapo cleaning CDs won’t work, you have to pop the top, and clean the laser lense with alcohol and a Q-tip. Now to install the secondary IDE channel again, you need to downlaod the latest chipset drivers for your motherboard. I dunno what kind of puter you have, or motherbard, but you need to find out what drivers you need to download. Appearantly, you’re trying to install the wrong driver from the message you’re getting, so I dunno what to tell you there. Some info about your puter might help there. Then after you get the driver installed, you’ll need to QUIT FLASHING THE DRIVE, that’s not the problem. Open it up and clean the laser, or chuck it and buy another. I’d clean the laser, it’s very easy to do. Just take the 4 screws out of the bottom, pop the face off, and you can see the laser lense after you remove the top. GENTLY scrub the lense with a DAMP, not dripping wet Q-tip. DON’T push hard enough to bottom the laser out or bump it all the way to the side. It’s kinda spring loaded, and floating in a suspension mechanism. If you push too hard, you’ll mess up the allignment. After you clean it, put it back together. If it still doesn’t read, chuck it. It’s garbage now, what have you got to loose??? I think it will be good as new after a cleaning. Just flash it with the latest herrie’s firmware if you want a good one. :rolleyes: :Z


#8

ok if xp you can always rollback the driver. if you are getting this kind of message just click CONTINUE ANYWAY you did the first time :rolleyes:


#9

oh yeah and the 25x0 suddenly not able to read… well if you look around you will find a large amount of threads about that… seems its read is not even in the ballpark with the write. so the blindness is probably not a thing to do with the flashing and everything to do with the drive


#10

Well… my unbounded joy continues. My Windows XP disk doesn’t include SP2 and 12 virii slipped onto the system during reinstall, some of which were anti-anti-virus which wouldn’t permit SP2 to install since it contained antiviral software.

So now the machine is simply screwed. (All of this over a damned piece of hardware that has naught to do with core function).

With regards to the posts, I have a couple of questions (perhaps sarcastic).

  1. How does flashing the ROM introduce dirt into the drive (re cleaning)?

  2. And, why could the drive read all my disks BEFORE the flash, but not (immediately) AFTER. We’re talking instant anti-gratification here folks.

With regards to hardware, I’m running Abit IC7-G Max2 motherboard with 3 GHz P4 processor, geforce 4 video card, 1G of DDR RAM (Dual channel).

Since my ISP wouldn’t permit me to remain connected to the internet with my box squirting virii into the environment I have made myself a care package here at the office including a copy of Win XP with SP2 included, all the drivers and BIOS updates for my motherboard, and an antiviris.

Plan to start over with the reinstallation (all the way down to removing the partition to insure that I have no pesky boot sector parasites) when I get home… and it sure as Hell WON’T be plugged into the internet while I’m doing it.

Wish me luck! (Sadly, I doubt it’s going to matter at all, I think this burner is deserving of some hard whacks with an aluminum baseball bat instead of praise – well, from those of us stupid enough to flash the ROM at least).

And I beg to differ with you on one point, I DO think it was the ROM flash – it’s the only variable that changed in an otherwise functional equation.


#11
  1. flashing the rom has nothing to do with dirt on the lense, he’s just recommending a solution for your drives read problems. I don’t think its the lense (but its worth trying), I think its simply a badly burned disc that cannot be read reagardless of the firmware version.

sorry to hear about your viri problems. reinstalling the secondary ide is usually automatic, did you try rebooting more than once? Also you have the 875 chipset, so there souldn’t be any unrecognized drivers loaded.

good luck :slight_smile: get some good antivirus software.


#12

sigh Well, I’m back up and running operating system-wise at least.

Out of 20+ disks that USED TO READ FINE BEFORE FLASHING THE ROM only one of them will read now, and of that one, it can’t successfully read all the files… In fact, it can only read 1 file.

Personally, I think there’s a descriptive word for my NEC 2510a right now, “junk.”

Now, I’m going to bed, when I get home from work tomorrow I’ll try cleaning the lens. And if it gets no better, I’ll be going out to purchase that alumimum baseball bat. I’ll post again including pictures of what this piece of crap looks like smashed to hell. Ever since watching Office Space and spending 7 years single handedly administering 70 computers (the very reason I’m less than reasonable about “glitches”), I have no misgivings whatsoever about smashing computer equipment to pieces. In fact, I can’t even begin to tell you the profound satisfaction it brings. :bigsmile:

So, someone please suggest a reliable DVD burner that works, is decently fast and not finicky about blank media and won’t magically metamorphose into junk if you happen to flash the ROM. Oh, and is reasonably priced.


#13

2 suggestions.

  1. stop using packetwriting. discs are cheap and packetwriting is inherently unsafe since the data is not locked in. don’t believe me? put one of those discs in with incd or whatever disabled and if you open nero it will treat it as a blank and let you try and burn over the top…

  2. the drive can still burn but not read. so stop trying to read and get a $20 reader. if none of my burners could read i would still have enough able to read that i wouldn’t miss a step. the read optics are one of 4 discrete subsystems in there the burn and read lasers are separate so 2 burn (cd and dvd) and 2 read (ditto) you will find many threads that say “i can’t read cds” same with dvds. far fewer of them, compared to the amount of drives, say they can’t burn. as long as it burns well why bother replacing it?