NEC 2510 - Stopped reading/writing DVD's (firmware)

vbimport

#1

I used the flasher on NEC’s website and it fixed the problem. Very odd since I was using the exact same firmware using binflasher I d/l on this site.

Hey guys, long long long time lurker first time poster.

How the problem started:

  1. I bought some new fujifilm 1x - 16x dvd-r’s because I am almost out of my 1x - 8x fujifilms I bought a few years ago.

  2. The burner couldn’t read the new fuji’s so I flashed to newest firmware (maddog).

  3. Now the drive only reads CD’s, and cannot read or write DVD’s (even the old fuji’s)

I have tried:

  1. Power supply is good (antec smartpower) and no problems with ide cables (tried switching stuff up)

  2. Offical firmware and a few other firmware versions, but they all give me the same problem… help!

Thanks for any input!


#2

I think that your drive’s DVD Laser may have kicked the bucket :frowning: These NEC 2500/2510’s are great drives, but I’ve read quite a few of them lose their DVD laser as they age. I still have one and it works fine, but then it only gets ocassional use at this point.