NEC 2500A dvd problems

vbimport

#1

So maybe I’m going to be asking noob questions and find out I am missing something simple, but right now I can’t figure it out.

I have a Maddog Dominator DVD burner (NEC 2500A) that has been working just find for the past year and a half. I normally just use it for burning Data DVD’s to help with storage. Recently it started having problems burning, and I would get discs that weren’t properly burned or some of the data would be corrupted. Now in the past month whenever I try to burn something a DVD it will only burn about the first 800 or so megs before the rest is corrupted and unreadable.

From personal observations it seems like it is only recognizing DVD’s as CD’s whenever I put a blank dvd in. It still reads already dvd’s just fine, but I want to get this fixed and don’t know how to go about it. Any help is much appretiated.

-Luo out


#2

First rule is to use better media.
What exact media have you used and burnt how fast??


#3

I haven’t tried with a different type of Disc, so that may be my problem (we’ll see) Right now I have been using Imation DVD-r 8x.

I was able to burn a couple of DVD’s just fine with these discs before everything went to pot.


#4

As far as I remember that drive only supports 4x +R writing - you may try 4x media; only 2510 writes on -R media; but I might be wrong.


#5

Only difference between 2500 and 2510 is the DL+ capability of the 2510. :wink:


#6

And they both burn at 8x.


#7

Yeap, my fault, I was thinking about the 1100 - that was my first DVD writer … old times… use to pay 4$ for a 2,4x +R media… memories strikes back.


#8

Only $4? My first CD-Rs cost me DM 15 per piece, 2x rated. That’s ca. €7,40.


#9

Ok, it’s been awhile but I haven’t had any cash to attepmt any repair processes. I bought some different Blank DVD’s and the Burner is still reading them only as CD’s. I then tried uninstalling my DVD burning software, and of course that did not work. So basically I’m stumped and am afraid that I’ll just have to buy a new burner, unless anyone can give me any suggestions here.


#10

did you try to update the firmware and then it will see more media???


#11

There isn’t really a firmware update for this one, I did update as much as possible, but that didn’t help.

Also, if it was a firmware problem I think I would have been having problems since the begining, I’ve had the burner for over a year and it has only started to mess up in the last few months.


#12

You could try the 205D firmware from Liggy & Dee’s website. It’s updated for alot of the latest media & has solved a few problems reported here recently. Get it here .

However, it probably won’t help as it’s more likely your 2500 is failing, but worth a try anyway.