NEC 2500a, Can't Enable DMA

vbimport

#1

I’ve been trying to enable DMA on my NEC ND-2500a that I bought from newegg a week ago but it just doesn’t want to change from PIO. I tried to change it from the device manager (I set it to DMA if available) and after reboot, it stays in PIO mode.

Does anyone else have this problem or know a solution? Or if it’s easier, could you point me to a thread that has already answered this question?

I have a cd burner (the one that came with my dell) on the same ide channel set to dma. Both the cd-rw and 2500a are set to cable select.

Here are the rest of my computer specs:

Windows 2000 Pro
1.3 GHz Pentium 4
256 RDRAM
GeForce 4 Ti4200 128 MB
NEC ND-2500A DVD-/+RW
160 GB Western Digital

(Sorry if this has already been asked. I’ve read a lot of topics but none have addressed this problem specifically. I’m a newbie)

Many thanks!


#2

In my own experience cable select has given me nothing but trouble try changing the two drives to master and slave with the nec 2500 as master and let us know how you get on.


#3

If that doesn’t work it’s always a good ides to try a new/different (80 wire) IDE cable.


#4

Maybe you can take a peek here


#5

Thanks everyone for the replies!

I switched to master/slave and then uninstalled the driver on the IDE channel and it worked like a charm.

Thanks for the quick responses.