NEC 1300a/NForce2/SI Controller DVDR Playback Help!

vbimport

#1

Recently needed to replace my Albatron KT400/VIA with a new Asus A7N8X-X rev2 NForce2 board. Before that I had bought a 6600 GT that simply would not work with the Via chipset on that board. After a sold month of trying EVERYTHING under the sun I replaced the board with the NF2. When I got the new board I did a Windows repair (to many apps & data to simply do a reformat). Everything went great. After the repair I was left with SP1 which I upgraded without trouble to SP2. I had a choice to install either the Asus NForce2 MB chipset drivers or the Nvida Universal drivers, I chose the later of the two. All I can say is I went from blue screens of death, fatal exception and not being able to play a single game to complete stability and round the clock gaming! During this month long NIGHTMARE the only thing other then the MB that was replaced was my PSU, got a 460w Enermax.

I have a NEC 1300a DVD-RW w/1.0C firmware which is hooked into a Silicon Image 0680 ATA/133 Controller. The NEC is now and was during the VIA days connected to the Master on the Secondary Channel of the SI Controller. This drive had been rock solid. I could throw just about ANY disc and burn / play back without error, until now. Ever since the change over, VIA>NForce2, I am consistently getting discs that have 1 or 2 glitches in playback on my Pioneer standalone. The odd thing is the 3 different media types (which used work perfectly) all pass verify in DVD Decrypter and Nero CDSPeed is not giving me any errors and perfect arcs in the test graph. The media would be my first place to look but all three media types worked perfectly before the switch. In fact one type I had already burned 1/2 the 50 pack without a single problem before the switch. So I have decided there must be something wrong with the burns. Here are the things I have done:

  1. First I checked the Event Manager and noticed during the burns IMAPI was starting and stopping several times during my burns. Disabled it with no effect.

  2. Verified that DMA was working on all drivers. My NEC is and has always been setup has DMA2 Multi-Word.

  3. Double check to make sure the IDE / Power cables did not come loose during the switch. Also worth mentioning is that the IDE cables are the exact same cables as the ones on the VIA setup.

  4. I also reviewed the IRQ’s in XP. Noticed that my brand new 6600GT and my SI Controller were sharing the same IRQ. While this did not create any blue screens or lockups or gaming trouble I decided to correct this. Went into the BIOS and disabled the onboard NIC (did not use it), COM and PAR ports that I was also not using. I also rearranged my Controller Card and PCI Nic. Everything is worked great, no more sharing IRQ’s. This however did not fix my burn/playback glitches. The Nvidia IDE Controller is using 2 IRQ’s, guess one for each channel.

  5. I also reinstalled; DVD Decrypter, ASPI Layer. Reset DVD Decrypter to defaults.

  6. Also played back some of my older burns (when things were good with my NEC) in my Pioneer to verify that my standalone was not the issue.

I have read about the horrors of the Nvidia IDE Drivers but aside from this playback glitch I have no other problems. No lockups/blue screens and no bad sectors on any drives. My Device manager reads the following for my IDE ATA/ATAPI Controller: NVIDIA nForce2 ATA Controller (v2.6). If the recommendation is to dump this driver in favor of the MS IDE driver how does that work with the NEC running from an SI Controller. Doesn’t the SI Controller have it’s own driver and does not need to access the nForce 2 IDE driver? Also, the images I am burning are on HD’s that are also hooked up to the SI Controller. XP is installed on an HD that is connected to the Primary IDE Controller of the MB however.

Wow, I am really sorry about the lengthy message. If I can resolve this EVERYTHING in my computer universe will be balanced again. Oh one last thing I have a CD-RW drive hooked up to the Secondary IDE Channel of the MB. While I have not tested extensively I have burnt 4 CDRs without ANY issues.


#2

The drive should to run at UDMA2, not MW-DMA2. Connecting it to the motherboard’s IDE port, using Mircosoft drivers, on different port than the source drive, is the standard way to use a DVD drive.


#3

Thanks for the help ala42. I can try this method but on my old VIA board this is exactly how it was setup and it was MW-DMA2.

When you refer to port, are you talking about IDE Channels? On the SI Controller it has it’s own Channel and is not shared with anything else, Primary port / Secondary Channel. The HD’s that I typical burn images off are on the First Channel of the SI Controller and they both use the First and Second ports.

Lastly, drop the NV IDE drivers? Even though I am burning CDrs without issue, getting no lockups, blue screens or sector errors on the HD’s?


#4

Well, if you keep everything as it is now, the problem will not disappear :). PCI IDE controller and NV IDE driver are known to cause problems, use the forum search function to make up your mind. MWDMA should be is fast enough for 4x burning, but it is still not the transfermode you should use. With IDE port I mean IDE channel.


#5

You are right, the IDE Controllers are not recommended for optical drives. I know cause I originally had a Promise controller that had discs for breakfast, back in the VIA chipset days. The SI however is known however to be OK for optical drive connections. It might be time for a change however. As for the NVidia drivers I have read enough horror stories to look at that as my main focus. The one thing that nags me is that everything that I came across with the NVidia IDE are more apparent problems. What I mean are problems like lockups, discs stopping in the middle of a write, burnt discs that show up empty etc. My problem is 1 or 2 small glitches during play back. They are not show stoppers but they are there and they can be seen even on PC playback.

Last night I tried something new. I decided to copy an image off the HD that is connected to the SI Controller down to an HD connected to the MB IDE Controller and burn. Without making any other changes or trashing the NVidia IDE drivers. It seems to have worked. I was able to play back the movie without trouble, don’t know what that means.

Here is some CDSpeed Disc Quality tests The first scan is the one that I just did yesterday but burnt on an HD connected to my MB, playback had no problems. The second one had a playback glitch, in the Extras of all places, but can be seen on 3 different players and PC drive. The last is one is burnt when I had my VIA setup with image burnt from HD connected to SI Controller and NEC Hooked into Controller. The last one looks like crud but I just played it on a player the other night that is know to be picky as hell. I am not trying to read to much into these tests as they are tested from my LiteOn DVD-ROM and the NEC 1300a has no support for the Quality Scans.