Nearly all DVD's won't play

Here’ an example of a few DVD’s that won’t play (listed below) on my VAIO’s OEM installed (Region 1) Pioneer DVD-RW DVR-K12D type DVD/CD-ROM drive(s) when using noted applications and players:

Various DVD’s tested (with results below):
Global Media Corp. 2004, B/W HQ DVD, “Ozzie & Harriet” (Region 1) K-MART PURCHASED
20th Century Fox, Widescreen, DVD, “I, Robot” (Region 1) NOT BOOTLEG

Intervideo WinDVD 5 or WMP 10 won’t play or even recognize that
the DVD’s are present. Tried both autostart and manual play.

DVD Identifier, v4.2.0 [OCT-23-2006] and even v4.3.0 [FEB-18-2006]
defaults to DVD+R/+RW tab and instead of identifying the media further,
reports only “Unable To Initialize Disc In Time : Not ready -
Incompatible medium installed” [02/30/00]

DVD Decrypter, version 3.5.4.0 (Lighting UK!) fails to recognize the disc
stating only “Device not ready - Incompatible Medium Installed”

DVD Shrink, version 3.2, fails to recognize the disc stating only "ERROR:

Unable To Initialize Disc : Not ready - Medium not present [02/3A/00]"

And when using my HL-DT-ST DVDRAM GSA-5160D USB Device (Region 1) type DVD/CD-ROM drives, the following results are observed:

DVD Identifier still fails to recognize the disc. It reports “ERROR :
Unsupported Medium Detected [02:42:44] INFO : Disc Identification
Requires DVD, HD DVD or Blu-Ray Recorder And Matching Media”

DVD Shrink identifies these discs and proceeds to preview them.

DVD Decrypter reports “Disc not empty” and does not display the clips,
etc., nor will the decrypter icon un-ghost. However the drive info typically is as follows (ref. “I, Robot”):

HL-DT-ST DVDRAM GSA-5160D A302 (USB)
Current Profile: DVD-ROM

Disc Information:
Status: Complete
Erasable: No
Sessions: 1
Sectors: 3,972,479
Size: 8,135,636,992 bytes
Time: 882:48:29 (MM:SS:FF)

Physical Format Information (Last Recorded):
Book Type: DVD-ROM
Part Version: 1
Disc Size: 120mm
Maximum Read Rate: 10.08Mbps
Number of Layers: 2
Track Path: Opposite Track Path (OTP)
Linear Density: 0.293 um/bit
Track Density: 0.74 um/track
First Physical Sector of Data Area: 196,608
Last Physical Sector of Data Area: 16,468,414
Last Physical Sector in Layer 0: 2,238,943

Layer Information:
Layer 0 Sectors: 2,042,336 (51.41%)
Layer 1 Sectors: 1,930,143 (48.59%)


And yet another DVD (see below), while my players again won’t work on it,
and DVD Shrink works, but DVD Identifier reports somewhat differntly with
“ERROR : Unable To Initialize Disc : Not ready - Medium not present
[02/3A/00]”, and DVD Decrypter reports again somewhat differently with
“Device Not Ready (Medium Not Present)” and in this case, the disc info
dialog box displays nothing whatsoever.

Ref. 2003 Showtime Entertainment Networks Inc, “Things Behind The Sun” (Region 1)


As the mentioned discs are pristine and regional codes are not of issue
and both the OEM Intervideo WinDVD 5 and the 3rd Party WMP 10 players
refuse to recognize/play these discs, I’m left to believe that the
optical drive’s drivers or decoders might likely be the issue.

Of note, I have downloaded a number of codecs intended for use with WMP
10, and I have also tried to locate plug ins, but as for installing
either of these, I’m at a loss as to how to do it (despite my previous
efforts at doing so). That alone would seem the most likely cause to my
issues, or so I might guess, given my level of noviceness.

Note again, I have no problems viewing/playing these DVD’s if using my
external rewriter or my LiteOn recorder-player and yet there seems little
to no difference in how 'Identifier, ‘Shrink’ and 'Decrypter fail/succeed
in how they report these discs.

As to where and how to start to resolve the issues of multiple DVD’s
refusing to play as well as them not being identified by 'Identifier,
'Shrink, and/or 'Decrypter, I’m led back to this being more likely an
issue with my OEM optical drive and its decoders.

If not as I suspect, and the optical drive or player is bunked up, I ran across a link (lost it though) to an application that is supposed to identify where the optical drive is filed so as (I assume to enable tweaks or diagnosing it).

As for the players (WinDVD 5 and WMP10), it wouldn’t surprise me that they’re partly in issue here, but as both players work fine with these DVD’s and the DVD’s also play well in my portable DVD player, I leaning more towards this being an optical drive issue.

As for trying to reinstall the players(as maybe they are bunked for my internal optical drive), ideally a wise thing to try first, the best place to start, but WinDVD is OEM (accordingly difficult to identify which Sony update actually installs it) and add/remove doesn’t offer WinDVD 5 anything but “remove”. And WMP 10 can only be rolled back to WMP 9 (no repair feature in add/remove) and is a beast to reinstall as it has always resulted in listing every media file I have despite my unticking files I don’t want it to associate (wav, music cd playback, etc.).

Thanks in advance for sharing any expertise, moreover for the time and energy.

What about this?
http://club.cdfreaks.com/showthread.php?t=169406

What about it?

Your setup/Os is b0rked.

And doubleposting is not allowed, by the way.