ND6500a In Dell laptops?

[qanda]This thread is about the NEC ND-6500A. Click here to see full specs[/qanda]Hi,
I’m sorry if this seems a stupid question but I have been struggling with a problem for weeks and reading various threads in this forum has just made me more confused.
I have a Dell Inspiron 8600 laptop which came with an NEC ND-6500A DVD writer in the removable docking bay.
A few weeks ago one of my colleagues needed to burn some DVDs and not having a burner I gave him mine.
I decided to purchase an identical drive off ebay. Big mistake. It wasn’t a Dell drive but from a different laptop.
I inserted the drive into the caddy and slid it into my laptop and hey presto it worked straight away no problems… or so I thought. The next day when I rebooted the laptop, I got a message saying that the device in the system modular bay cannot be identified, so I removed it and rebooted. Again no problem. Then I inserted the drive & it works fine. Windows device manager shows it as NEC ND-6500A.

I tried to update the Firmware using the Dell site but it will not recognise the drive.
I downloaded the latest firmware from the NEC site and again it says no supported drive found.

I have the firmware from the old drive I used NEC Winflash to dump it and I’ve tried to restore this to the new drive without success.

My guess is that I have a Master/ slave issue but I am not confident enough to be sure.

Can anyone point me in the right direction PLEASE?

BinFlash supports flash/extract for ND-6500A drives
The master/slave setting is in the firmware

Jethro thanks for the prompt reply.
I understand that the settings are in the firmware but I don,t understand how BinFlash shows them. When I run Scan I just get the version levels
showing

Bin flash does not show master/slave, use binflash to re-flash it to the dell firmware.

That is what I tried
I get a message saying ‘Probably mixing up master & slave firmware
This is very likely to DAMAGE your drive or make it INACCESSIBLE It is not allowed to continue here.’

Good advice, but I have done the flash both ways more than once, the drives work fine.

Following on from the message saying it doesnt allow me to continue I get another message saying Id from drive:85, ID from firmware:84.
Then another popup saying Firmware is for a different drive.

How do I bypass these errors and force the Flash

Is the 6500a you have using the 4.xx firmware? If so than it is the reversed-ATA used on some laptops and will indeed need a hardware mod to flash. Sorry I thought you just had some 2.xx variant.

If I use Nero Infotool 5 It says the firmware is 4.60 and it is attached to Secondary IDE Channel

look for the 403e firmware to flash it

If the 403e fails to work than here is your only other option.

  1. Take the DVD out of the laptop and find the 47 contact on the IDE socket
  2. Take a 300 Ohm resistor and solder it to that contact (1/4 watt)
  3. If you connect the other part of the resistor to the case (ground) the drive becomes master and if you solder it to the +5 volt the drive is found as slave

Thanks for all the help Jethro.
I finally sorted the drive out.
I flashed with the 403e but it didnt fix the problem.
In desperation I flashed the drive using the master bootcode flasher on Liggy’s & Dee’s 6500 Firmware page.

This set the Drive as a 6100a, but the laptop booted OK and recognized the drive. I then reflashed the drive with the dumped firmware from my original Dell drive and hey presto I’m fixed with a Dell spec Nd-6500A. The firmware from that drive turned out to be 203e

Glad you got it sorted out.