ND-6750 bitsetting firmware 2.41 already available?

vbimport

#1

Hi,
i’ve just installed my new 6750 and i’m a little bit confused about the firmware. It came with 2.41. I’ve searched here but found nothing about it, also i’ve looked on L&D’s page and there are two versions available 2.P1 and 2.01. So i guess 2.41 is a newer version or from iodata? Could someone clarify it. And will there soon comin a bitsetting version? :wink:


#2

2.41 probably is an OEM firmware. Not sure from which OEM, but 4 might be Fujitsu.
But don’t expect any bitsetting firmwares when I don’t even have the non-bitsetting version. :stuck_out_tongue:
You could however dump your firmware and upload it. :iagree:


#3

Yes, it’s an oem drive for fujitsu. I’ve just uploaded the file.


#4

Any change you could upload it to me too?

http://www.micheldeboer.nl/firmware/upload.html


#5

Just done!


#6

I did reverse ATA and installed 2.p1 on 6750. It works very well in my Toshiba. Thanks Liggy! However I also noticed the 2.p1 from NEC is very outdated compared to the other version. I just wander Liggy can update slave firmware based on 2.41, like you did to 7550 1.p1. Thanks!


#7

It’s possible to convert a master to a slave firmware, but I still wonder what I should call these versions since NEC doesn’t change the first letter anymore. Maybe 2.q1?


#8

As i can see there are some changes between 2.41 and 2.01?!


#9

Hi, Liggy:

2.q1 is a good name. I do not think NEC will release any slave firmware soon. Thanks!

BTW I tried to flash 6750 with 2.p1_rpc1 with Binflash 1.27 gui and got a “supplied file does not contain a valid firmware” error. Then I tried 2.p1_fast and got the same result. I downloaded again and again, still the same. What did I do wrong? Thanks!


#10

This problem was reported already and I think it should be fixed with the files I uploaded about 7 hours ago. But if you say that you even downloaded again and your post is just 3 hours old, it looks like I need to investigate this issue again.


#11

I’ve just flashed the 2.41rpc1 version works good. Thanks Liggy.


#12

Hi, Liggy:

Thanks! The 2.p1_rpc1 is working now. Sorry, I forgot to mention that my last try was 24 hours ago.


#13

Is this in reference to the .zip files themselves or the .bin files within the .zip files?

UPDATE: Guess it was the .bin files. But did this affect any other drive firmwares too or just the 675x?


#14

@cchang
Thanks for the update and confirmation that it’s working again now

@tghoang
Each firmware file contains an identification at the end of the file that shows on which drive this firmware is expected to work. I just copied the identification from the original firmware file without remembering that the identification used there (a special slave firmware ID) was not recognized by Binflash. So I just changed this ID to the correct one.