ND-6650A not recognized by Asus L5800C

vbimport

#1

Hello,

I have an Asus L5800C Notebook, and it came with a default Toshiba SD-R6012 which sucked from the begining. So after 2 years I finally bought a replacement: NEC ND-6650A. However, when I replaced the drive, the BIOS doesn’t recognize it :frowning: Even pulled out the harddisk to see whether that helped, but no luck. Since the BIOS didn’t recognize it, Windows XP didn’t either. The drive does have power, tray opens, etc, but just not recgonized.

Any help would be very appreciated :slight_smile:


#2

Does it say anything about an “IDE” error when you boot up?
If so, you may need to do reverse ATA. How did the Toshiba SD-R6012 show up before you removed it? {Master/Slave - Primary/Secondary IDE)


#3

I think your right about the reverse ATA stuff.
My Toshiba appeared as Primary Master, my harddisk as Secondary Master (ASUS logic I assume :slight_smile: No error though.

So no slave, thus maybe the drive is set to slave at the moment. (Weird, brand new)
How can I reverse that? Only with new firmware or are there other tricks?

Thanks :slight_smile:


#4

Yes, you can solder pins 45 and 47 together to force the drive to Master.

See this thread.

http://www.cdrinfo.com/forum/fb.asp?m=94889

It’s talking about the NEC 6500, but it still holds true for the 6650.

You of course would do the reverse ATA for the 6650 if you choose not to try the solder trick. See Liggy & Dees page…

http://liggydee.cdfreaks.com/page/6650


#5

Thanks :slight_smile:
I’m not a very good solder, so I wanted to use Liggy’s Reverse ATA Package, but it gives an error:

Processing … Please wait a few minutes.

And then withing 2-3 seconds, I get the error ‘Another Error’

When running the ‘Normal’ 6650boot.bat, it gives me :

Drive is Already Normal ATA Boot

So the reverse ATA thing is somehow not working for me…

(Tried this with a Slimline -> IDE-adapter on a PC)


#6

Ah, well… it worked finally :slight_smile:

Maybe nice to put into the notes that ‘Another Error’ could occur when you have the drive attached to your Primary IDE Controller, instead of your Secondary :slight_smile:

Drive is now flashed and seen by BIOS.
Thus, for some reason, the Notebook sees Primary as Slave, and Slave as Primary. Completely reversed from what the PC sees :slight_smile:

Thank you for all your help & suggestions, I’m a happy person now :slight_smile:


#7

I think you mean master instead of primary here. :slight_smile:

I think it’s possible to also make both packages work with primary instead of secondary adapter, but this would mean I had to change the batch scripts from NEC and I’m too lazy for this :wink:


#8

Hello I have a similar problem with an asus notbook a2h. I have only an ide channel where the HD is the master and the dvd is the slave.
Excuse me the silly question but which contraindications I should have by
configuring the hdd as slave and leaving the nd-6650 configured as master.