ND-3520AW Read Problems? Stupefied

vbimport

#1

My burner seems to be acting weird with burned dvds.

I have Aopen AX4GE Max MB.

I have single HD as a master on the primary channel.
The burner is the only one on the secondary channel as a master.

The firmware of the drive is at NEC official 3.04.

Running Windows XP pro.

I believe it reads CDs just fine, but when reading DVDs, it acts up.

When I insert a burned dvd (data DVD not burned on ND-3520AW) in the drive, it spins up with high speed(I can hear it)… when I go to “my computer->dvd drive” and click on certain folders, the speed (noise) dies and hangs… hanging also affected some of my USB connected drives where they disappear and appear again. The content of the folder eventually comes back but I can’t run or copy any files from those particular folders (I get crc errors and copy fails.)

I thought it may be the IDE cable so I swapped it out with another 80pin but still the same. I tried to move it to the primary channel and set as a slave but problem persists.

I thought maybe it was windows XP issue so I tried it on windows 2000 and still the same problem.

I can copy and run same files from the burned dvd on my laptop’s dvd-rom.

Could this fixed using software (firmware/driver/etc) or is this a hardware problem?

p.s. I have not tried burning a dvd on ND-3520A and reading it again. I’ll try that tonight.

Thanks.


#2

Try to delete this drive from the device manager and reboot the computer and go to bios to set this drive to auto detect. Make sure the master/slave setting is right and at last check the ide channel to make sure it’s running on DMA mode 2.