Nd-2510a Doesn't Read CDRW

vbimport

#1

hi,
i just got this drive and burnt a dvd fine.
but it is having really very hard time reading and exploring CDRW .
it just says please insert disk in drive E:
dvdinfo and nerocddvdspeed says media is there and even lets me erase from nerocddvdspeed but can’t explore.
sometimes says “function not available” sometimes “Please insert disc into drive E:”
I tried with Memorex as well as Verbatim cdrw, both same. I tried same discs in different computer and they work good, donno what’s wrong. It read an audio cdrw but doesn’t give me option to erase when i right click the drive.
now it’s not even reading blank cdrw.
anything i can try here?
thanks


#2

You probably still have the stock firmware of version 1.06. Download DVDInfopro and see which one you have. Then download Herrie’s hacked firmware v 1.07v2beta4. This will improve the reading ability as well as the reading and burning speeds.


#3

will do that, i’ve attached the pic of that info.
it says the firmware revision is 2.15
i thought it has 2mb buffer but it says it is 256kb.
is it easy to install new firmware? i mean is it just like updating driver or i have to go somewhere to do it?
thanks



#4

It was easy for me, especially since I had the Windows FW updater. I just clicked on the firmware EXE file, it asked me if I wanted to updated it. I said yes and it did it within 30 seconds. Then you restart and you’re done. As far as DOS based flashers I don’t think you’ll need to worry about those ones. Just get the ones that are Windows based and you’ll have no problem at all. Just a click of the button, really.


#5

cool
now it won’t even read blank cdr
not only that the existing dvd rom also doesn’t read the blank cdr and cdrws.
when i insert the bland cdr, windows doesn’t give me the box asking what i want to do with blank discs…
the only thing different in the existing dvd rom is it is now in secondary ide as i hooked nd-2510a in the primary. messing up more…

already burned cdr plays fine :s
i tried the windows updater from harrie’s but it says can’t find 2500 (is it only for 2500?)
thanks



#6

You need to flash from DOS if your using a 2510 and want to use Herries 2500 v1.07b5 firmware.


#7

Trouble with CD-R/RW discs are usually due to either packetwriting software (InCD, DirectCD, DLA) or Windows built in CD writing service ( IMAPI ).
Uninstall/disable these features and then try burning/accessing your CD-R/RWs again.