Nasty problems with my LDW-451S, help!

vbimport

#1

Before I formatted my hard drive, my drive worked just fine when I wanted to burn or read discs. Now it refuses to read data discs, such as my game CDs, but can still read music CDs and burn just about anything, and I have no clue what is happening. I was using WinXP Pro SP1, but after the reformat I now have SP2 installed, I dunno if that is the problem or not. LiteOn won’t help me and neither will Microsoft, and to make matters worse, my new install of Linux on my second hard drive is having problems using the drive, so I’m pretty convinced that it is either a hardware problem or a BIOS issue.
Whenever I put a CD in, for example Vampire: The Masquerade Bloodlines, it spins up and acts like it is trying to read it, then keeps trying for a minute or so then stops, and the CD appears blank. Before, it would spin up some, then it would stop and the green light on the drive would blink on and off slowly 3 times, then do nothing. I found out IMAPI support was off for some reason, then I turned it back on and it quit blinking like that, but it still says discs I put in are blank. I also tried turning off DMA, and updated the firmware with the latest from LiteOn, but neither helped. If I try to run the game the CD is for, it says the CD isn’t in the drive. I know the CDs are still good because they work fine on my WinXP Pro laptop, as well as a friend’s Sony laptop. What is going on with my drive? Do I just need to get a new drive? Or do I need another reformat? It’s making me insane, please help me! >.<


#2

I’ve noticed something else that seems to happen whenever I can finally get a data CD to work and try to install something, I usually get the following error message: Data error-cyclic redudancy check. Maybe that will provide some answers…


#3

That’s odd. Is the HDD reformat / XP reinstall the only thing that happend before the drive stopped working?

Can you get a bootable CD and try to boot up with the drive?


#4

I tried that, and it seems to boot ok for the moment…unless it is a Linux live CD, then I get all kinds of errors, namely bad sector errors when it tries to make the ramdisk. Knoppix is the only one that seems to work anymore.
And the drive seemed to be fine after I reformatted at first, then it started going insane. I unstalled Nero, which fixed some things (I think it corrupted some drivers), but it is still misbehaving.


#5

Bad sector errors–as in it’s unable to read from parts of the CD? (sorry, I haven’t used a live CD before, so I’m unfamiliar with the process)

If that is the case, then, chances are, the drive may have developed some sort of physical problem (could be just about anything… parts wearing out, dust on lens, etc.) and that it happened around the time of the reformat may just be a coincidence. If you want to be 100% sure, you could try the drive in a different computer to make sure that it’s not something weird coming from the computer side.