My SOHW 812s@832s can't read any DVD! Help, Please!

vbimport

#1

Hello. (Please, excuse me: my english is very bad).
I have a Lite-On SOHW-812s@832s (I don’t see any error messages when I upgrade the drive). Recently, I try to burn a DVD-R 4X (Princo) and the process fail (it was very, very slow, almost one hour). Now, my drive can’t read/write any DVD (retail or DVD±R/RW). It can only read (sometimes) one DVD-R Ritek I burn before the upgrade. I beleave that the problem is the firmware or the hardware (drive) because it can’t read in Windows XP nor Linux.

Any suggestion?

wicho.


#2

Try clearing your Eeprom.

Possibly you might need to reflash your drive.,

Princo media and AN31 (both possibly the worst possible quality media in the world) have been known to do this.

Go here:
http://club.cdfreaks.com/showthread.php?t=83441

Download No# 11 -> Eeprom utility & then hit reset learnt media.


#3

Hi, debro, thanks.

I will try your suggestion later. I forgot to say that my drive read and burn very well my CDs. This change your advice?

Ok. I have another question: The EEPROM in my SOHW-812S is different to the EEPROM from another SOHW-812s? If the answer is NO: Is possible found (via e-mail or so) a copy of this EEPROM and load it in my drive?

Thanks in advance.

wicho.


#4

I’m not debro, but…
I very recently had an issue like yours: working CDs, not working (at all) DVDs. I solved the problem checking the IDE cable: maybe a false contact made my drive malfunctioning. After I substituted the cable, everything came back OK

Ok. I have another question: The EEPROM in my SOHW-812S is different to the EEPROM from another SOHW-812s? If the answer is NO: Is possible found (via e-mail or so) a copy of this EEPROM and load it in my drive?

Thanks in advance.

wicho.

The EEPROM is ABSOLUTELY unique for each drive. You can’t use the EEPROM’s .bin from another drive.


#5

OK. First, I tried the debro suggestión (backup and clearing the EEPROM [reset learnt media]), but the problem persists…

Next, I tried changing the IDE cable (thank Stargate64), but nothing happen… (I will try changing the IDE port later [and, maybe, changing the computer…]).

In this moment the situation is the following:

The drive can read and burn CDs very well and fast, but can not read/burn any DVD media. Sometimes, it can read only the first DVD inserted in the day…

Kprobe2 can (most of the time) identify the DVD media in the drive with the STPI driver, not with de ASPI driver…

If Kprobe2 identify the DVD media, why the other programs (Nero, DVDShrink, and de Windows Explorer) can’t see it…?

Windows XP have de ASPI drive (v 1.71, I think). Installing de 1.60 version can make any difference?

Any idea, please?

wichito.


#6

@ wichito
If you want to try the ASPI 4.71>4.60, you can get it here. Let us know if it works.


#7

Excuse me if I misunderstood your post and you did this, but I would also follow the rest of debro’s advice

Possibly you might need to reflash your drive.,


#8

Reset learnt media = Didn’t work.
Changed IDE cables = Didn’t work.

Try reflashing your drive with new, or even the same firmware version (not the firmware already in the drive)

Do you have any programs installed which check all inserted media, ie; Anydvd, creative disc detector, windvd remote, etc;
Disable them (even if just temporarily.) Most of them, you can hit Ctrl+Alt+Del & kill them, rather than making permanent changesv to your system.

Aspi! versions 4.60 (1021) was the last release which most people can agree was stable. I found 1019 to be slightly more stable, but shrugs.
Versions 4.7 & above have issues.

If none of these work, then try the drive in a different PC.
If the problem persists, it’s the drive & needs to be returned.


#9

I apperar to be having the same problem :sad: Tried reflashing the firmware and clearing learned data from eeprom, no luck there either. looks like it’s time for a new drive :sad:

Klorel


#10

… or time for better media :slight_smile:


#11

Been using datasafe 4x + media, I know they aren’t the greatest media but they are the best i’ve been able to get locally.

However my problem like wichito’s is reading original dvd disks. Could using crappy media kill a drive?

Klorel


#12

I’ve some how managed to solve this problem today :slight_smile:

Not sure which of the following sorted it but this is what I did anyway.

1st I downloaded Omnipatcher v1.3.18 and firmware version US0Q

I applied the recommended DVD media tweaks and applied all General Patches exept for the force-fallback patch.

Now I flashed the drive Using Firmware Flashing Tool v1.0.0

I should have tried the drive again at this point, But I didn’t. Sorry.

Then I uninstalled the following software: AnyDVD, CloneDVD and PowerDVD.

Next I looked at the driver files the drive was using in device manager, made a copy of them then deleted them from the system32 and system32/drivers directories. then I uninstalled the drive in device manager and rebooted the pc.

Once it rebooted I got a message asking to reboot again because some registry settings had been changed (should have made a note of this but I didn’t sorry.), I did another reboot.

Then I put in my queen of the damned DVD and was presented with a InterActual Player setup, I wasn’t aware of the software on the dvd, but I allowed the install anyway.

After the install the dvd played fine :slight_smile:

Tried another DVD just to make sure, which is playing fine too.

Klorel


#13

Just tried reinstalling PowerDVD and the problems started again, took it back off probs gone.

So try binning powerdvd if your using it.

Klorel


#14

@ Klorel
Nice work!:slight_smile: I am glad that worked for you. Thanks for sharing with us, so others may try that solution. The more software a system has that does the same job or uses the same devices, the more chance there is of a conflict. Keep us posted if anything else changes/develops.

InterActual Player is a bundled dvd player software that appears on many dvds to access their web-based features among other things. It has been known to cause conflicts as well, but maybe not in your instance.


#15

Thanks please.

Klorel