My problem with auto-bitsetting on CG3B/812S

Excuse the potential “Newbie-ness” of this question, but:
I have a LiteOn 812S, flashed with CG3B run through Omnipatcher with the only alteration being to set “Auto-bitsetting”.
I am using TDK/Ricohwpn11 DVD+RWs and the bitsetting is not being applied automatically. I am burning with Nero
If I use the LiteOn bitsetting application before burning it will set to DVD-ROM with no problems and be read in all my other devices, but if I do not it still reads as DVD+RW. I have run the patch again, and re-flashed with the same results.
Am I making any fundamental errors here, or is there a software compatibility issue that I may be unaware of?
Any advice greatly appreciated.

yes it is the new nero it has removed auto bitsetting for liteons (why i dunno).
you can either do as you are doing now using the bit setting tool from liteon or…use omni patcher to auto bitset and revert back to nero or earlier ( is the last version to enable auto bitsetting).

Thanks for the reply. I assumed that by using omnipatcher to auto-bitset that this would over-ride Nero’s lack of bitsetting. So I was wrong, and Nero must “co-operate” with the auto-bitsetting feature? It is not a major problem to remember to bitset manually, just would have been more convenient to have it done automatically!

if you revert back to then it does auto bitset. and to be honest i have had no bother with that version of nero on anything. 1:1 copies and burning dvd images and creating data or video compilations…
the reason it does it is that omnipatcher auto bitsets the dvd to -rom then when nero over rides it and resets to +r

Got it. Appreciated, thanks.

I’ve got nero and all my discs come out as dvd-rom. :o

seems like a random thing lol might be original litons come out as -rom and rebadged come out as + or vice versa…i do know that Intensecure isnt the only one with this problem…and everyone who reverted back gets the auto bitsetting back as well…
you must be 1 of the lucky ones lol

And I did revert - and got my auto-bitsetting working! Saves remembering to do it with the LiteOn utility, because surely soon I would forget! FYI, it’s an original LiteOn 812S flashed with CG3B - which is awesome.
Thanks for your help the_hetster.

The auto-bitsetting patch takes affect only when the drive is initialized (when the system boots up or right after a firmware flash), and it does so by setting the default bitsetting value. And that’s the effect of auto-bitsetting; it doesn’t do anything else once that default value is set upon initialization, which means that it’s quite easily to have some piece of software–KProbe, LiteOn’s booktype utility, or a misbehaving version of Nero–override that setting. Never will autobitsetting override a software setting.

Never will autobitsetting override a software setting.

Thank you for clarifying that, and you have obviously noted that I posted the same observation in two threads re. use of Nero and auto-bitsetting. I read both your responses and value your input.
Now I really know what is going on! I am sticking with CG3B with auto-bitsetting, and Nero .17, although as previously noted, it is a bit irritating having surprises sprung upon you and therefore fear for future versions of this software and it’s features.

its not really neros fault lol…
i use .25 and have the autobitsetting feature but that is becuase i have sony VY06 firmware instaled on my liteon. when i revert back to 832 firmware the option is gone…yet another indication that it was in fact liteon that asked them to remove the feature from liteon drives. although i have heard nec autobitsetting feature is gone in .25 as well
oh i dunno lol

is there any version of nero that will let you set the booktype of iso burning to -ROM?

i know that nero automatically sets the booktype to -ROM for DVD-Video burning. why can’t they just add an option in nero to let you choose the booktype you want at the time of burning?

that would be sweet if they’d just put it right there on the burn tab right where the ‘number of copies’ and ‘burn speed’ settings are.

I quit using auto-bitsetting. I burn with Decrypter primarily, and firmware bitsetting doesn’t work for me. When I tried using it, I couldn’t achieve DVD-ROM booktype (with or without bitsetting turned on in Decrypter). To achieve DVD-ROM booktype, I simply use that setting in Decrypter.

Please see my post here: