My Plextor PX716A doesn't work!

vbimport

#1

Hi. Today my PX716A finally arrived. Well, I installed it, the BIOS recognized it, and so did Windows XP SP2. However, not once was it able to read any CD or DVD. It came with firmware 1.03. I updated it to 1.04 - the problem wasn’t solved. I did the same for firmware 1.04u. No good. Windows says The request could not be performed because of an I/O device error. I tried uninstalling the nForce IDE drivers, and it didn’t help either. I even attempted to boot from a CD and it wasn’t really read (that dismisses the chance of this being a Windows-related issue). My drive says it was made in China, and its TLA code is 0203.

My mobo is an ASUS A7N8X-E Deluxe with BIOS revision 1013 (the latest). The 1.04u firmware claims to resolve motherboard compatibility issues, and it was my last resort before seeking help from others. :frowning:

So, can anyone help me with this? Thanks.


#2

Hi ShinMagus!

In December, i bought the 716 TLA 0203, Made in China, like yours. Suprise, suprise, i install it, and didn´t work!

Everthink was recognised! The Plextor, capacities, etc,etc,but couldn`t read, record nothing!
I try, 3 diferent IDE Cables, MASTER ( default ), slave, alone, without more Drives…format OS…nothing…

After 2 days, desesperated, send it back to the Store! By telephone they told me that he was working! Can you believe it??

Any way, send it Back! RMA with it. Thats the solution. Isnt your board, cable, or any Hardware/software. :sad:

That`s the opinion from someone that have the same problem here in Portugal…but maybe there are in the this fórum, someone, that can give you a better advice… :stuck_out_tongue:

At this moment, i`m also considerating send this mine to RMA, but for another reasons…
My Specs on Hardware:
Abit NF7 S 2.0 Bios d26-mantarays-xtAMD XP-M 2500+ 45W 2700 MHz 1.95V
Plextor 48x + Plextor PX716A(TLA#0204) + LiteOn SOHD 167T HackedSpeed 16x

OS Windows XP with no Nforce drivers, and NO SP2 :smiley:

Good Luck!


#3

The curse of countries where people speak Portuguese? o__o
:frowning:


#4

LOL


#5

:stuck_out_tongue: Quem sabe, meu caro, quem sabe…

Boa sorte!


#6

I got same problem! Exactly same! :eek:
(TLA#, Mgf Date, Mainboard model, just except Windows!-I use Win2000 Pro SP4)
I RMA’d to Plextor week ago. I didn’t get yet. I just wait to good one. :sad:
(I spent too much $ for shipping. :a )


#7

My PX712A didn’t work with when it’s first arrived. I RMAed it, the replacement still didn’t work. I then read something and bought a PCI-IDE card, as soon as I hooked it to the PCI-IDE card, everything works perfectly.

The problem is the IDE controller in your motherboard. If it a “Promise” controller, it is known that they are bad for DVD-RW drives. Get a “Silicon image 680 chip” based PCI-IDE card (I got mine for $17 from pricewatch.com) and hopefully the DVD-RW whould work. Let me know your reaults.


#8

arkhan: Hmm. You mean something like this? http://www.compusa.com/products/product_info.asp?product_code=50159179&pfp=srch1

arkhan: the funny thing is, the drive worked flawlessly from NOV-Jan, and now looks like it is shot for some reason. Started (as posted in other post) with not burning correctly, and now it doesn’t even recognize any media (blank or retail) in the drive when opening in Windows).


#9

Same exact problem here, Did not note the board revision but it was made in china, was recognised but read was DOA, I switched to Pioneer DVR-109 seem to be a better deal so far and 25% cheaper not counting the postal rebate of the Plex, My previous drive was a PX-712, It was ok but no DL …


#10

Actually have the same problem here: Ive RMA’d a 716a - about a month ago - at first it worked great, then after a while it just stopped detect any media (pressed and burned - cd’s/dvd’s), then i got my new plextor 716a, with latest rev. (TLA 0304, fw 1.04 - now 1.06), did never work on CD’s(pressed or burned), but works flawless on DVD’s - and this i dont get… Plextor must have some serious problems with these drives, ive gotten a RMA confirmation for this drive, (3 weeks ago) but havent sent it yet… too damn frustration having no dvd-rom in pc. The first i never had to return, so its laying around, most curious if someone come up with an idea of what is wrong… maybe i can fix it and have 2 drives??! :wink:


#11

I’ve posted extensively on this issue, as I went thru 2 bad drives, and a hellish experience w/Plextor U.S.A. Bottom line for me, no more Plextor, which is unfortunate, because Plextor drives do things other drives don’t.

Anyway, if you haven’t already been told, run the Plextor hardware diagnostic. Your manual tells you how. Without looking it up, as I recall you have to disconnect the IDE cable, do something w/the jumper (can’t exactly remember, but manual has a picture), put a disk in the drive, hold down the eject button while powering up the system, and wait while it runs thru an internal diagnostic. At the end, the LED light will blink green, either one blink or two blinks, over and over, w/a short pause in between blinks.

Again, please do read the manual, as I am recalling the diagnostic steps from memory–you don’t want to hose up the proper sequence.

I forget what one blink means, but both my bad drives had two blinks, which means “initialization error”.

My drives started out great, then gradually began to produce errors in reads and writes–small ones at first, then more and more until the drive finally refused to even read a disk, much less write one. This is the pattern I have seen reported here, and on other forums.

I am happy for the people who managed to get good 716A’s that are still working, and I wish I was one of them. Tho, having now replaced that drive w/an NEC 3520A, and added another drive–an LG GSA-4163B–I have most of what I had w/the Plextor… for a total cost of less than what the one Plextor cost. :Z


#12

I got my third px716, same rev as the last one, but this has been working for one week now, with no problems at all… but to be honest… im just waiting for it to fail :S anyway hope it doesnt, since Plextor have been my fav cd/dvd-burner company :slight_smile:

RX


#13

So my latest(se post) px716 has been working since ive got it, and still does. But does anyone know why these drives failed… curious since ive still got my first px716(never needed to return it, just got new from rma), and if it is something i could do to fix it? TIA


#14

Maybe this?

http://club.cdfreaks.com/showthread.php?t=142059

Good Lucky!