My PC doesn't recognize my CDRW

Hi,
This is my first inquiry on this forum and I hope it will be responded effectively even if it may be basic.
I bought an Archos SlimCDRW (model 1/020602457). With the aid of an Archos support person, and using a tppinstl_5_04.exe file I managed to bring to use on my home pc.
When I followed a similar method on my office pc (win2k pro, pentium II), I failed. Installation ends with the following lines on my Device Manager:
Universal Serial Bus controllers:
Intel 82371AB/EB PCI to USB Universal Host Controller
USB Root Hub
! USB Storage Adapter V3 (TPP)
The first line is an old item.
The second - a successful addition
The third - a failured addition.
The message I get for the third line is:

"This device cannot start. (Code 10)
Click Troubleshooter to start the troubleshooter for this device.

What went wrong and how do I solve my problem?

Ran

I’m a newbie to CD Freaks and was searching for the Device Cannot Start Code 10 problem and found your message. Did you ever find out what the problem was? I also am getting the same exact error and it’s driving me nuts too! I really want to use my new drive (a Memorex 48X24X48X). My former CD-RW (A Polaroid 40X) worked fine and I’ve uninstalled all the CD-RW software just as you did.

Has anything worked for you?