My New ND3520A doesn't work

vbimport

#1

Hi all,

I need the help from you guys. I just bought a new ND3520A from NewEgg. I already have had a 8xLiteOn RW before I bought this one. My computer is Dell 4600, only have two IDE interfaces. I am using the primary IDE for two HD drivers, the Secondary IDE is for two DVD writers. The operating system is WinXP Pro.
The NEC was set for ‘Master’ and LiteOn was ‘Cable Select’. I opened Windows Explore, I found the two drivers can read the content of disk, but don’t work for blank disks. If I only connect NEC, it works for content disk and blank disk. I later tried different suitations.

  1. NEC Master, LiteOn Slave,
    blank disk x blank disk OK
  2. NEC Slave, LiteOn Master
    blank disk x blank disk OK
  3. NEC Cable Select LiteOn Master
    blank disk x blank disk OK
  4. Both Cable Select, LiteOn works for blank disk.

I also check the ‘Device Manager’ and ‘CMOS configuration’. They don’t have any error information and showing right hardward: NEC ND-3520A. The driver of 3520A is Microsoft driver 5.1.2535.0.

Please help me to figure out this problem. By the way, I did not update the firmware. I downloaded the driver, but I got the error message when I was running the software,

‘Target NEC ND-3500A is not found correctly’. In addition, my LiteOn driver label always is E, and NEC always is F. No matter how I changed the jumper or cable, the disk label never switched.

Thank you for your help.

joyo


#2

why u use CABLE SELECT for your Liteon??? use slave setting!


#3

I tried it. It doesn’t work either. It looks like that NEC won’t work if I connect with another driver.

Thanks

joyo


#4

Try a motherboard bios update. Also try replacing the cables with new ones


#5

Connect only one dvd-rw to ide 2.Lite on doesnt like nec:)


#6

Could you explain why?

Thanks


#7

I observed a similar behaviour on via kt600 motherboard… i put it in an external usb enclosure and it works.


#8

we have only dells @ work. for some reason dells do not like setting the drives as master/slave (for both hard drives and optical drives). try putting both your burners on cs.


#9

Boot into BIOS and verify that all hard drives and optical drives are seen and set to use AUTO detection. Save and exit. Reboot and go to Device Manager and remove the Primary and Secondary IDE channels. Reboot and verify that devices 0 and 1 in Primary and Secondary IDE channels are set to use DMA mode. Save and Reboot. Verify that all devices connected to Primary and Secondary IDE channels are running in DMA mode. Make sure the jumpers on the hardware are set to Cable Select OR Master/Slave if there are two devices connected to the IDE channel.


#10

I just got a 3520 and hooked it up as master with my Lite-On 832s as slave. The BIOS wouldn’t recognize the Lite-On. I switched the 832 to master and 3520 as slave and everything works fine. Guess the Lite-On just has to be the boss.