My Lite-On 20A1S started burning only at 2x?

Hello. I’m having a strange speed issue with my PC and DVD burner. My Lite-On 20A1S 9L08, used to burn just fine at 16X. The other day I set a real TYG02 DVD to burn with nero at 16X, and it took 24mins to burn. I noticed too that while nero was burning, the buffer level was fluctuating constantly. Ex. up to 99, and down to like 13 etc. I re-installed the drive, and nothing changed. I re-flashed the firmware (which is the best one for this drive) and still no changes. Last night I did a nero create disc burn to see what was really happening. Below are the results. I don’t think there’s something wrong with the drive, it starts off by spinning up like it usually does, but then slows down to a speed around 2X. I think it may be a windows related issue. Perhaps I may have turned off some process or setting? If anyone has any info or advice that could help me, I’d really appreciate it. Thanks in advance, :slight_smile:
~Jason

A High CPU usage and extreme buffer fluctuations are typical of a disabled DMA.

I suggest to check the DMA status. Can you run also a Burst Rate test with cd-dvd speed?

I’ll try and report back thanks,
~Jason

How do I check the DMA? Also, when my pc is just idling, my cpu % averages between 0 and 4%. It only goes up when I’m burning.

Here’s the burst rate. There was a closed DVD in the drive at the time but that shouldn’t make a difference.


Check in my signature the link on DMA :slight_smile:

Ok, I’ll check that out.

Well… the only thing that was set to pio only was the device 1 under secondary ide channel. Everything else was set to DMA if available. I changed it to dma if available and rebooted. It now says DMA if available, but under current transfer mode it says pio? I’m not sure why, but I tried another nero create disc and it’s still burning only @ 2X. =/

Well I reset the events using the file from rapidshare, and now it’s all better. Thanks for your help.

If in “current transfer mode” is shown PIO, then DMA is not enabled.

Try to uninstall IDE drivers and reboot: this should solve :slight_smile: