My LG GSA 4167b works only in PIO mode

vbimport

#1

After 2 weeks my LG GSA 4167b won’t work in dma mode. First it crash my Windows. After format c and reinstall windows xp pro sp2 works only in pio mode. uninstall and reinstall ide channel. problem persists. config:
MB - Gigabyte VT 600 1394
Proc - Barton 2500+
HD - Samsung SATA 160 GB
VGA - Gigabyte 55128
Audio - MAudio Revolution 7.1
I change evrething. power supply, ide cables etc. I don’t understand. Why it works 2 weeks and after this … Now 30 min to write an DVD (16x). I change a lot of media also (Sony, TDK, Verbatim, Samsung). Nothing’s change.


#2

Have you checked the BIOS? IDE channel may have defaulted to PIO…change to
AUTO, save and exit.


#3

I did this already. It is in auto now


#4

Xulescu, there’s a small program that can help you. It’s called DMable. I can upload it, if you want.

DMable.zip (7.15 KB)


#5

The other thing you can try is to uninstall your IDE drivers. Once you do that, Windows will reboot and automatically install its own default IDE drivers. Certain IDE drivers can cause that problem with DMA refusing to be enabled.

And if that doesn’t work, here is a guide to dealing with stubborn problems when DMA refuses to enable itself :

http://www.michna.com/kb/WxDMA.htm


#6

Thank you guys but nothing worked. Karangguni, i use the link. after i aplly the vbs file it turns in udma mode 2, but computer hangs a few minutes from time to time and the drive is dead. So i need to uninstall the ide channel driver. I think it recived errors in dma mode


#7

How is your drive connected? I am assuming it is jumpered as master on the primary IDE channel. Is that how you have things set up?


#8

No. Is master on secondary, because i read that for lg is better like this. but i tried also on primary


#9

Some LGs are recommended to be connected as Slave’s, I’ve read.


#10

I put it also as slave. I erase upper and lower filters already. nothing.


#11

It’s posible to be from PSU. Sirtec 360w truepower


#12

You might want to try putting it on the primary IDE channel. LG’s instructions say to put it on secondary because they assume you have an IDE HD connected on primary. They don’t take into account the use of SATA hard drives. Also, you can try jumpering the drive to CS (cable select). There are a few computers where DVD writers will only work detect correctly as UDMA2 if they are jumpered as CS. I don’t know why.

Lastly, you don’t have any other device sharing the IDE cable with the DVD writer, do you?


#13

I tried already all the posibities. Nothing change. I think is defective drive


#14

Any other ideas


#15

Have you tried changing the IDE cable? It could be defective.

If that does not work then there is only one last thing to do : connected the drive to another system and test it. If it still won’t detect as UDMA2, the drive is probably faulty. If it does get detected as UDMA2 and works fine on that, then it might just be an issue with the IDE chipset on your system. I have no idea how to fix that sort of problem though.


#16

Have you tried with a firmware update? Maybe it can help…


#17

what ide driver are you using?


#18

Karangguni. thanks a lot for all your help. i’ll try to check in another computer, but right now i have a broken leg (gypsum) so i have to wait for movement. keepin’ touch.
Pejakm the firmware is DL13.
RBTPL windows driver


#19

Oh dear! I am out of ideas, really. Hope you get well soon though. :slight_smile:


#20

Try with DJ13 (buffalo firmware).