My games dont work on ps2

vbimport

#1

i dont know what is wrong with my comp. i know my swap magic 3.3 is working properly because my friend lent me Devil May Cry 3 and it worked perfectly.

i have tried to burn GTA:SA, The Punisher, PoP: Sands of Time, NBA Street, MGS and all of them didnt work. i put it in the ps2 and the game starts up but after a while the game freezes either in gameplay or during the cutscenes

i have windows xp, nero/dvd decrypter, Ritek G04 and TYGO2. Burn at slowest speeds, NEC 3500A

NOTE: i have burned over 10 movies on Ritek G04 that worked perfectly
NOTE: For GTA, the TYGO2 froze much later than the Ritek GO4
NOTE: the disk my friend lent me had media code MCC 02RG20


#2

Buy originals.


#3

Try some verbatim discs and read\burn them with dvd decryptor as this has always worked great for me…
Maybe the TYGO2 discs are fake…


#4

Heh . . .


#5

maybe my ps2 is very picky since i burned movies that are really good

can there be any other problem with my system cofigurations?

is MCC 02RG20, verbatim?


#6

Yes it is sorry never read your first post correctly
Use dvd decryptor and select mode\iso\read to read and mode\iso\write to write (best with dvd-r discs or dvd+r bitset to dvd-rom)
Try it in both consols and see what you get…