My first scan

vbimport

#1

in Linux :bigsmile:

This is an older SUSE 10.0 / i848P mobo system, with the latest Wine 0.9.30. Not quite 16X speed and no Capture button, but all else seems to be working.

Who still needs Vista now?! :stuck_out_tongue:


#2

Hi :slight_smile:
Especially with the little waves goodbye at the end of the scan. Very polite. :bigsmile:


#3

Yeah, could be Wine that’s limiting the speed, I don’t know. Haven’t really done any 16X-plus burning in Linux. :slight_smile:

Some additional info: it’s possible to get the capture buttons back by using unmanaged windows (also requires gdiplus.dll to save the .png). Create Disc works for Data Disc, “Burn Image” gives an error. “CPU Usage” doesn’t work either and “Simulate” seems to have left burn traces on this disc, it’s not empty (but not burned readably either) after the test.

The second screenshot was done in Windows for comparison. Pretty consistent. :cool:




#4

Been playing with WineTools and “Burn image” & “Simulate” both work now. The Disc status was still Empty after this test.



#5

What did you change? :slight_smile:


#6

WineTools actually over-writes part of Wine and allows you to install additional basic Windows system software like DCOM98, MDAC, VB Runtimes and such. It’s a pity I can’t seem to get it to run in CrossOver Linux though (similar to WineTools, but not free). Decrypter & Shrink really fly in there, CDSpeed might burn/read over 16X…


#7

Yay! :clap: USB-scanning (with the external Sony) works in Wine. This is the same disc scanned twice. It was burned @16X with the internal BenQ using K3b and didn’t reach 14X either. Buffer problems and slowdowns from ~3GB. So I’m happy to report that the speed problem is not with Wine but with SuSE on this box.





#8

Well, as y’all can probably tell, I’m very pleased I got this working. :slight_smile: Here’s a quick recap for anyone who might want to try it:

  1. Get a matching pair of Wine and WineTools packages and install (current would be 0.9.3 - I used rpm’s and YaST in SuSE).
  2. Run the WineTools setup (Alt+F2 and enter “winetools” - run the Base, system software and TT fonts setups).
  3. When complete, select the “Modify the Wine configuration” option and set the Windows version to “Windows 98” (CDSpeed starts up much faster this way).
  4. Under the “Drives” tab and “Show Advanced”, change your optical drive’s “Type” from Autodetect to CD-ROM.
  5. From a Terminal, you should now be able to run CDSpeed (cd to the correct folder and enter “wine CDSpeed.exe”).
  6. Here’s two links that I googled to get my USB drive up in Wine:
  1. For those wanting a nice CDSpeed icon to put on their desktop, I’m attaching one I edited with the GIMP.

Good luck! This is just my experience, no guarantees or support on my part obviously. Now show us your scans, Linux fans! :wink:


nero_cdspeed_icon.zip (6.61 KB)


#9

Also working on sig-machine under openSUSE 10.2 x86_64 with Wine 0.9.24 (as offered by YaST), haven’t installed WineTools yet. Using nVidia SATA striped and SATA burner. No more speed problems with internal drive. :slight_smile:



#10

It seems the drive must be installed as a SCSI device and not IDE for this to work (/dev/sr0 etc. and not /dev/hdc…). Anyway, SATA drives are on the up, so that’s good news. :slight_smile:


#11

Everytime when I run CDspeed.exe under wine I get “no Cd-rom drives”. I configured wine properly following Cressida’s steps.


#12

Welcome to the Forums, [B]pYr0[/B].

You’re probably not using a SATA drive? I believe that for PATA (IDE) drives to work, you must be using the “ide-scsi module” (which is now deprecated in the newer 2.6 kernels).


#13

Thanks for reply

Yes I’m using pata drive and kernel 2.6.21. I tried to load ide-scsi module but I got “not found” result. Is there any way how to get it working? I don’t want to install windows just becouse one program that don’t run under linux. I like linux but scanning dvd feature is really missing me :frowning:


#14

Not that I know. The easiest solution is to install a SATA drive, you can still use your PATA drive for scanning in an external USB enclosure afterwards.

P.S. In OpenSUSE 10.2 I haven’t needed WineTools anymore.