My DW-U18A dead?

vbimport

#1

:confused:

I recently tried to reflash my drive back to the standard stock firmware but during the process of mtkflash, the floppy crapped out on me and gave data errors and was forced to abort the process and of course, rendered my drive inoperable. :sad:

I’ve tried using mtkflash again with the stock firmware and i’m still getting nothing. I even tried flashing with other variants such as the 812 firmwares and still nothing. I can’t even get a light as well as the tray to open and BIOS is not detecting it. I’m on an ECS K7S5A mobo with an SiS controller I think. Any help please!

Praying…
:bow:


#2

Firstly you should only use mtkflash if your drive is dead. There are other tools you can use to flash the firmware if you want to return to original firmware.

mtkflash should restore you drive. My guess is you are using the wrong command line switches. Follow the instructions on this site to correctly reflash your drive using mtkflash for dos.


#3

I have… I’ve got v1.80.1 and I’ve been using :
mtkflash 3 W UYS1.bin
The command goes thru the entire process of erasing chips and reprogramming them and there are absolutely no errors during the entire thing.

Am I still doing something wrong?


#4

Also, using MTK WinFlash, i got this error:
ERR: fail to identify the flash type!


#5

MTKWinFlash does not work with DVD burners. If you want a Windows based flasher the recommended one is the Firmware Flashing Tool.

Try moving the drive around on the IDE chain. Most people say Secodary Master with no device on Secondary Slave works best.

Also try this command as it’s been reported to help as well (the /m switch erases the banks so it will flash clean):
mtkflash 3 w /m uys1.bin


#6

Yes, Ssseth is right on point… :wink:

If this doesn´t work try MTKFLASH v.1.69. I have been using this version with no problem. (Don´t forget to add /B in command line.

And remember, all these commands only work if you have the .BIN file on a floppy (A:>).
If others, you have to point to the right file with your commands.

In some rare occasions even all this wont work. Then find an old $ntel(P-II,) or VIA computer and flash the drive there. Primary Slave (2).

:smiley:


#7

I just tried those methods and still nothing. I’ve also hooked it up to an Asus P5A mobo and got the same results. And yet another question comes to mind. If I were to flash the drive with the firmware that I am applying (UYS1.bin), wouldn’t I be able to back it up (backup.bin) after a “successful” flash and get a BIN file that should be byte-for-byte exactly the same as the original UYS1 file I applied? Maybe this would help in further repairing the drive.


#8

Yes, they should compare okay if it was successful.

So you’ve tried the /m flag… thinks… have you tried using version 1.80.0 instead of .1? And is the .BIN file okay/undamaged? Exactly 1048576 bytes in size?


#9

I’m going to try the 1.80.0 version in a few moments. I can also post the extracted BIN file from the recorder and it did come out the same size as the one flashed. I did the DOS FC command and I would think that the files would be exactly the same but if I did the command right, the files did differ at many addresses. So either I’m not doing it right or I’m doing it right and the flash isn’t recording.


#10

code65536…

You are the man once again. I used the 1.80.0 version and it worked perfectly. Sorry for the lateness in my reply but I was in Las Vegas overnight and it was freakin’ awesome to get this fixed before I left. I meant to post this up before I left but we literally had to leave just after I flashed it.

Thanks to all and everyone that helped. Mostly for not flaming or shitting on the thread.


#11

Mind if i asked why you wanted to return your drive to the sony firmware? I recently go the 18a sony and immediatly flashed it to 812s bit setting patch. Course im having troubles i bought a spindle of Onidtech 4x media at the store making the huge mistake of trusting the guy when he said it was good media that would work with my new drive i was also getting. I wonder if id have better luck if i went back to the original firmware. of course its not too late to exchange to a 2500a or a real 812s not sure what that would accomplish though.

thanks

Admiral Ackbar


ITS A TRAP!


#12

Some people claim that the U18A firmware (UYS1) does better with -R. As I almost never burn -R, I can’t confirm this…


#13

Pretty much the reason I went back… I have the better half of a -R spindle i have left that I got when I bought the recorder. I didn’t see much of an improvement in recording time (on my setup including speedhacking) so I’d rather leave it to the way it was until I get a better one or better media.


#14

ive got a similar problem,m sony dw-u18a will open but wont read anything,the orange light is blinking or flashing all the time,how do i reset te firmware to original eveything…
please help!!!


#15

hi, edwinhj.
Try to edit your firmware with the omnipatcher and set the last option “dead drive blink”/enable-crossflashin and reload the firmware, or if you want to return to the original firmware user the mtkflash version 1.80 from dos with the following command: mtkflash n W /M /B UYS1.bin ( n= 1 prim. mast., 2
prim slave, 3 seq master , 4 seq slave).
I hope this information helps you .
Regards.
DPV