My DVD burns corrupt files

vbimport

#1

Actually, it’s not a mystery why the files are corrupt.
If you take a look at the bottom side of the DVD’s burned,
they look like this:

Small image (and accurate) image:
http://img93.imageshack.us/img93/6105/baddvd8ur.th.jpg

Large (but inaccurate) image:
http://img93.imageshack.us/my.php?image=baddvd8ur.jpg

Does anyone know what the problem is?
And preferrably, how to fix it?
The writer’s practically new (barely 3 months old).
And it’s burned only about 50 DVDs.


More info:
I’m using an ASUS DRW-1608P2S.
Using Nero 6.

I have a VIA chipset motherboard, so I had to turn off DMA.

The last 5 DVDs I burned were like this.
The 6th one and prior were all perfect.


#2

Looks like problem with your media. Can you try with other discs.
Use DVD Identifier to identify your media.

BTW, you’ll have to rearange your HW setup to be able run your burner in DMA mode. Make a search for VIA (+chipset numbering like 133A, 266A…).
Are you still on Win98?, your thread here.


#3

I’ve tried with 5 different brands. Verbatim, Imation, etc.
I even tried it with a CD-R.

The blank DVD/CD starts off clean on the bottom.
Then it becomes
http://img93.imageshack.us/img93/6105/baddvd8ur.th.jpg
after burning.

I have a running count right now of 10 DVDs, and 2 CD-Rs.
All with corrupt data.
The first 5 DVDs are the same brand.
The last 5, and the 2 CD-Rs are all different.
Still the same results.
There’s still this “line” that seems to have nothing burned on it.

Meh. If worst comes to worst,
I’d just take it back while it’s still under warranty.
I just wanted to know if anyone else experienced this,
and if there’s an explanation for it.

Oh, and I’ve given up on DMA.
I can get it to work most of the time, but the occassional coaster isn’t something I like risking. And I don’t like how it’s a ***** to disable DMA on Win98’s safe mode. The option is disabled for crying out loud… I actually have to dive in the registry everytime… gets to be too much of a hassle.


#4

A burner will not burn corrupted data.

Only the quality of the media seems to be crap here.
And maybe the IDE cable too.

[B]Also, this burner must run in UDMA4 mode!![/B]


#5

Why do you have to disable DMA, just because your mainboard is VIA based? :confused:
I never had any problems concerning DMA on my VIA based systems. Maybe you have installed wrong drivers. Depending in the particular chipset, either 4in1 or Hyperion drivers are enough. But stay away from the special IDE drivers VIA offers unless you run exact one of those chipsets VIA mentions in the description of these drivers.

Michael


#6

It’s virtually impossible for a burner to create that pattern on a disc.


#7

Do you want me to take a picture?
Or are you just calling me a liar?
Why would I make it up anyway?

And as I said, I used a LOT of different media brands already.
Or did you just nonchalantly skip over that part entirely?

Hey, all I asked for was an explanation from someone who knew what it was. I don’t need hit-or-miss solutions anymore, I’m just gonna exchange it via warranty anyway.

And no, it does not HAVE to run in UDMA4 mode.
That has NOTHING to do with this problem.
DMA is just for addressing a speed issue.
DMA just bypasses the processor, by assigning the DMA controller (DMAC) to do a direct transfer between two hardware peripherals (in this case, from HDD to writer).

Take it from someone who writes DOS programs that use the sound card.
I know how DMA works, inside out. What interrupts it use, the channels it has, etc.
It will not create errors like this.

Old VIA mobos have dodgy support for DMA on optical drives. It’s EVEN stated here on the CDFreaks forum. That’s not the issue anymore.

It’s not the media that’s causing this, nor is it DMA.
I was asking someone to pinpoint what it was.
Although judging from the replies, I doubt anybody else here knows the root of this problem.

Oh, and I also have tried it on 3 IDE cables.
The one on primary, the one on secondary, and the one that came with it.
It’s all the same.


#8

That’s BS, really.
I have better things to do than arguing with someone here…


#9

Let me try to explain why it’s impossible for a burner to create that pattern:

The “stripe” you show is a straight line radiating out from the center. In order for a burner to create that line, it would have to interrupt the laser power at different points in the datastream in each revolution of the disc. Any sort of cyclic (regular) interruption in the burn would create a spiral or stairstep pattern. So it’s physically impossible for any sort of drive or datastream anomaly to create that radial line. Or to be more accurate: the odds of a hardware issue generating that perfect line is about one in a zillion. The most typical visable anomoly on a disc that’s caused by a FUBAR burner is banding.


#10

I know have an idea how burning works (it burns circularly from the inside, outwards), so yes, I know it IMPLIES that it stops burning at that point every rotation, which is, theoretically, just plain impossible, since it’s rotating at such a high speed.

Hey, I’m dumbfounded as well.
I’d happily mail you most of the corrupt burns if you’d shoulder the shipping.
I tried taking photos of it earlier, but I can’t seem to find a way to take proper pictures of a CD’s bottom with my cellphone’s camera (too much glare, not even the circular burn line itself is visible).

Although this site has “glare-less” pictures of CD bottoms.


If you can guide me on how to take these pictures without any problem, I’d gladly take a couple or more for you.


And, to chef, I have to admit that after lurking these forums for a while, I really didn’t have much respect for you even if your status is a “guru”. I’ve already seen you in the past continually force your “it’s bad media” argument repeatedly on what is obviously a hardware problem, even before this thread existed.

Just so you’d know, I brought my writer to campus and tried it on one of the PC’s there. YES, with your ever so lovable DMA enabled. And yes, the media was a spare DVD+R from the office. The burn was fast (5 minutes) but the problem persisted.

Here’s a newsflash for you.
DVD burning troubleshooting goes beyond “media brands being bad” and enabling DMA.
OMG! I hope it’s not too much of a shock.


Just a final clarification.
I’m not looking for a solution, just an explanation.
I’d rather not keep a broken writer I just fixed anyway, not when I can still exchange it under warranty.

Just an explanation.
Like:

"Why is my burning slow?"
Explanation: DMA is disabled for the writer

"Why does my PC hang when I access/burn cds/dvds?"
Explanation: Your mobo doesn’t support DMA, or it’s turned off in the BIOS.

Thos statements don’t tell you how to solve anything.
But they provide a PERFECT explanation of the problem.
It’s just that I don’t like NOT knowing what’s wrong with my hardware.


A little trivia:
"Why does my PC hang when I access/burn cds/dvds?"
Specifics: The DMA controller is waiting for the interrupt (a signal from a hardware device or a program) that initiates the next block of data transfer, since DMA transfers by blocks. But your mobo (or more specifically, IDE controller) doesn’t send this interrupt signal, since it doesn’t have DMA (ergo, when it receives a DMA request, it does nothing). Unfortunately, DMA operations occur on a kernel level, so it locks all your resources until it receives this interrupt (which will never come). In my opinion, this is bad programming on Microsoft’s part, for them not checking if DMA is actually supported on the mobo, because, as far as I can recall, it isn’t that hard to check if DMA is actually enabled. Most DOS games do this, because if they just started to try to play sound on a PC without a sound card, the (non-existent) sound card will never send the interrupt to start the transfer of the next block of music to play, so it’ll wait forever, hanging your PC.

Some games overlook this though, just like Microsoft windows did, and hang the PCwhen you turn on the sound in-game.