My DQ60 experience. Don't be hating

You guys have no love for the DQ60.

I had the DW1620 and after 5 months of use it died on me. It was the best DVD burner I ever owned right up until it died while changing disks. I liked it so much I went to buy another one. Nobody has 1620’s or 1640’s etc in stock. NOBODY. I mean I spent an hour and a half looking and nobody has them.

So I opted for the DQ60 which looked like a 1640 with better features like DVDRAM. I bought it on Newegg for $39 and paid for 2 day shipping. That was Sat. I got the drive today.

Yesterday I did some research on the drive here and was shocked to see that Benq apparently made a stinker. I couldn’t find one positive remark on these forums about the drive. I immediately began to regret my decision.

Well after performing various tests, rips, and burns with the drive I have some preliminary comments.

I’m using the newest firmeware from benq japan. version MRDC.

8x DVD video takes about 8 minutes.
Not any worse than my Plextor 708a.
It appears to be a CAV drive.
There is no riplock. I got a max of 8,426KB/s in DVD Shrink on Fight Club.
There is no book setting option :frowning:

The bad.
It burns my 8x Verbatims at 8x while my 1620 burned them at 12.
No booksetting

The good.
No coasters or read errors. Clean scandisk bill of health in Nero CD/DVD speed.
No riplock
Burns CDR’s fast. Windows XP SP2 only took 3 minutes, start to finish to burn.
Rips 700MB CD’s in around 2 minutes.
It’s dirt cheap.

I know how fussy people can be about the chipset not being Phillips. I’ve personally never cared about the chipset. But so far the drive seems allright. It’s not as good as my 1620 in terms of raw speed or utility. But it’s not that much worse either. Certainly not a big enough diff to keep me up at night.

It’s also a brand new drive so as they release new firmware the disc writing speeds and compatibility will increase and with any luck it should burn 8’s at 12 or 16x.

It’s kind of unfair to arbitrarily compare it to the 1640 because it’s been out longer and the firmware is more developed with a wider media table. Give it some time.

So far I’m not regreting my decision. And with any luck, booksetting won’t be far behind on the list of features.

Also, it’s undocumented in the specs but the drive supports the Mount Rainier drag and drop format.

http://kodacksdarkness.com/dvdshrink.JPG
http://kodacksdarkness.com/nero.JPG


Thank you for sharing your experience and thought with us here, for all you have written about your first work with drive I don’t think there is any room for regret you might as well enjoy it and worse come to worse is we only talking about $39 merchant just take as you have gone to a good restaurant and had $40 steak let’s enjoy it and have happy burning.

You are mistaken, the DQ60 does allow booksettings. You just have to use Qsuite to do it. Trust me, I’ve been through a couple of discs with that drive and all the + discs are set to dvd-rom whether it be single or dual layer. The only reason I return it is because the average read speed is so slow compare to the 1620. On the plus side, it will burn Ritek D01 dual layer discs at 4x speed and they play back perfectly.

Newegg has 1620’s in stock.

Well I RMA’d my 1620 but they are shut down for the end of the year so I won’t get my replacement until mid Jan.

Where do I get Qsuite? It didn’t come on the disk and the Benq site didn’t mention it on the product page.

The 1620 had the selection to do it under Nero. The DQ60 does not.

I’m not sure what you mean about average read speed though. Are you talking about disk ripping?

Can you give a real world example?

It rips DVD’s faster than my plextor 708a but seems slightly slower than 1620 and by slight I mean slight.

Qsuite is here:
http://www.benq.us/ServiceAndSupport/Drivers/drivers.cfm?product=782

Like the above poster have said, you can get Qsuite on the BenQ website. Yes, I do mean ripping speeds. It starts at 3._x and ends around 8x. My 1620 and 1640 rips much faster. I don’t have the DQ60 anymore so I can’t give you a real world example, but if you visit http://www.cdrinfo.com/Sections/Reviews/Specific.aspx?ArticleId=15843 you can find a review for the plextor 750 which a rebadge DQ60. Look under the Reading Speeds header and you will see how slow the DQ60 is compare to other drives.

That’s about what I saw. It started at 4x and topped out at 8x or so. When I get my 1620 back from RMA I can do some side by sides. Honestly though I didn’t notice it taking much longer to rip a DVD9.

And it can rip a CD in like 2 minutes flat.

Even on the DVD9 discs the 1620 is much faster because its starting speed is much faster and ends at 12x as oppose to the DQ60’s 8x. On the average it saves me about 5 minutes on a DVD9 disc. Sometimes even more.

I finally picked up some 16x Verbatim media and found out a few things.

First of all I know why it won’t burn my 8x at 12x. The drive does not support 12x burning. So if it can’t burn at 16x the next one down is 8. My 1620 could do 8x 12x and 16x, leaving some leeway for overburning 8x media.

The second thing is that at 16x it exceeds the bandwidth of both USB2.0 and Firewire. With USB 2.0 it began to dump the buffer at 50% into it and this slowed the writing down tremendously, finishing the burn at 12minutes.

I switched to firewire and it made it longer before dumping the buffer but it still was too much for the interface resulting in a 8:50 burn. At 8x it burns a disc in 8 minutes flat.

So I am about to open up my case and install it internal. It looks like it actually burns 16x discs at their full speed though. Nero’s estimated time for a full DVD was at 5 minutes. Lets see if it can hit that direct to IDE.

You need to update the firmware for your external enclosure, that will solve most problems.

Also realize the the DQ60 is still pretty new, benq is very good at issuing FW updates, for whatever reason it is not listed on their website (US), but I know there are like 2 or 3 FW’s that have been released so far. I did some quick searching and couldn’t find any of them for DL’ing.

Yeah I already updated to MRDC.

I just installed it internally and I was able to burn a full disk in 5:54. There were still 2 or 3 times the buffer dumped but it was 3 minutes faster than burning externally on firewire on 16x media.

And it’s 2 minutes faster than burning at 8x.

One thing that may make the buffer less effective is that the reported buffer memory is only 1419kb. My Liteon did something similar with certain firmwares. It’s supposed to have a 2000kb buffer so I hope they fix that in the firmware releases.

Hi folks,

Thus far, my new BenQ DQ60 has been pretty much a mess. I got it installed by the MDG folks (a local dealer here in Toronto) and paid a bit extra hoping to save time of installing, configuring, etc. It turns out they gave me my old system back and I could only boot Windows XP in safe mode after that. After some more digging, I discovered that there was an issue with the Vax347b.sys file (on the Windows\System32\Drivers directory). It’s the plug and play ROM bios driver. I uninstalled it and tried to boot back. Got back on and managed to get into Windows XP (without having to boot into safe mode).

But then, the DQ60 was not working properly (i.e. cannot even open the tray by hitting on the eject button). The green LED light keeps on turning on and off. I have no hardware conflicts on the device manager (the driver is working properly). I opened the box and it seems that all the cables are connected properly. I also went to the BenQ site and downloaded the latest firmware. Big mistake. It did not work (here are the messages I got):

BENQ DVD DC DQ60 Current firmware : FS01
==> New firmware Version : MRDC

Linear CheckSum : 9953
Rotated CheckSum : 6AF6
Check Sum match !!
Start to upgrade…
Don’t turn off the power!!

======== FAIL ========

I also got the dialog box saying “updating incomplete or interrupted!” :a

Does anyone have any clue?

Thanks for any assistance! :bow:

Hi :slight_smile:
I don’t have a DQ60, but a few days (28/12/05) ago I posted that there was new f/w. This post is under “Post new firmware ANNOUNCEMENTS here” to be found here.

To save ypu looking now it’s here. But remember to look at the f/w thread now & again. Happy new year to you all.
P.S. Latest version MREC:

New f/w:
Release Reason:

  1. Update writing strategy for DVD+/-R media.

Edit: BTW ala42 has made MediaCodeSpeedEdit available to you. :clap: :bow: :iagree:

Welcome to CDFreaks :slight_smile:
Usually the firmware version starts with MRxx. FS01 is the version number of the bootcode, which you see if the bootcode detects that the main firmware part is corrupted. The bootcode stays in a ‘safe mode’ which only allows flashing the firmware to recover the drive. As this does not work, return the drive.

It sounds like your drive is screwed up. I’m sorry to hear it.

So far I have found the drive to be average. Not great, not bad. I’ve burned one coaster in about 13 burns. It made it to the end of the disc and got a media error and crapped out while writing lead out. My 1620 NEVER burned a coaster the entire time I owned it.

I’ve found it to be a decent dual layer burner. One problem that still plagues it is the buffer memory. Even on a bus mastering IDE connection the buffer will start to under run the last 1/4 of the burn. I have a screaming fast machine with 2GB of memory so I hardly doubt it’s my system. IT’s a combo of the limits of the IDE architecture, and the fact that not all of the 2MB of buffer is available. Nero info tool reports 1.5MB of buffer, not 2MB.

My liteon was like this with early firmware, but it was resolved when I OC it with the 48X firmware.

@Ronaldinho
It’s not at all surprising that you paid MDG to install something that they didn’t even test before handing it over to you. Get a refund for the drive and the install service charge, and never never go near MDG again. I had about 3 or 4 experiences with MDG (two through friends) and I saw clueless salesmen who lie, incompetent techs, and non-competitive pricing.

Thanks for the tip. Given that all 16X media is better at 12X I will be giving this drive a pass.

I appreciate your post and efforts…saved me a potential cost of $40. And I had just gotten over the frustration of the 3 RMAs on my 1620.

Hi Ala42 and Kodack,

Thanks :bow: a lot for your help.

Yes, it was the DVD-R that was bad. Got the feeling that BenQ released something that is still pretty much a work in progress. They replaced the DVD-R and then, everything worked fine.

Thanks again! :clap:

FTP1020, I generally tend to agree with you, but every once in a while you luck in (I know I did yesterday). The service guy who attended me was pretty good and replaced the DVD-R after realizing that it was not working properly. The secret is to go straight to service w/o wasting one’s time w/ the sales guys, who are for the most part totally clueless.

You’re quite right, nothing beats doing it yourself, but I wanted to save time, which made this a frustrating exercise, since I had to debug, drive there again, etc.

Thanks,

Ronald

P.S. Since everything is now working, I did not dare download the latest firmware update from BenQ… :bigsmile: